Enabling hardware shaders crashes/freezes the display on my PC

Issue:
So, i’ve been trying to play Monster Hunter on Citra, everything is going great until my PC freezes and i can’t do anything else except holding the power button to forcibly shut down the thing.
I’ve also noticed that, though the PC display freezes for good, i can still hear the game playing as if it was working normally, even being able to blindly control my character or even closing the citra program through alt+f4, though the display is still frozen at the game image.
Through experimenting with the graphics settings, i’ve noticed that disabling hardware rendering fizes the problem, but in turn causes performance to drop to unplayable levels.
Searching through many posts and etc. for similar problems, i’ve tried to update my graphics drivers, but that didn’t fix the issue.

System Information

  • Linux Ubuntu 20.04
  • CPU - Intel® Core™ i7-7500U CPU @ 2.70GHz
  • GPU - Hybrid - Mesa Intel® HD Graphics 620; Topaz XT [Radeon R7 M260/M265 / M340/M360 / M440/M445 / 530/535 / 620/625 Mobile]
  • Citra Canary 1928; Citra Nightly 1678
  • Game: Monster Hunter 4 Ultimate; Monster Hunter XX

Diagnostic Log
citra_log.txt (4.9 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Accidentally reset the log file by opening citra. THis should be the correct one.citra_log.txt (15.4 KB)

Does it also happen on Radeon? Currently only Intel HD Graphics is being tested according to the log.

So, after reading your reply i’ve been ramming my head against a brick wall, because for some reason my system isn’t using my dedicated amd gpu, even though it appears when i look it up on my terminal, and my drivers are all updated. I’ve tried installing proprietary drivers to see if i could resolve the issue, but no luck there.

In any case, thanks for your help, i hadn’t realized my system wasn’t running the correct gpu, once i resolve that maybe my problem with citra will resolve itself.

By any chance, would you know how to handle this issue with hybrid graphics on Ubuntu?

Try this: https://starbeamrainbowlabs.com/blog/article.php?article=posts/254-run-program-on-amd-dedicated-graphics-card.html

Oh my god, it worked!

Thank you so much, this article pointed me in the right direction and now the game seems to be working perfectly, the logs now show the AMD gpu in the GL rendering, and previous parts qhere the game would crash my system are working.

Again, thank you so much for your help, i was about to give up on solving this issue after days trying to do it on my own.

1 Like