Error: Black screen with sound

Black Screen With Sound:
Hello everyone, I have been having a problem with the latest citra update, what happens is that when I start a game the audio is played but it always remains on a black screen, deactivating the option to activate hardware renderer solves the problem but the game becomes unplayable.

The strange thing is that in my previous laptop this did not happen and it was less powerful so I ask you to help me if someone has the solution, thanks in advance.

System Information

  • Operating System: Windows 10 Pro
  • CPU:
  • GPU:
  • Citra Version (found in title bar): Citra Nigthly 1708
  • Game: Pokémon Sun
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (98.8 KB)

System Information for Support

Client Version                                Nightly 1708 HEAD-e7671d9
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-4200M CPU @ 2.50GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4600
GPU Driver Version                            10.18.10.3308
CPU JIT                                       [x]
Hardware Renderer                             [ ]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from Intel’s website. Downloads for Graphics
  • Please enable the Vsync option if you are experiencing screen tearing.

GPU Driver Version: 10.18.10.3308

This driver is outdated, you will need to update it.

Download win64_15.40.5171.zip from https://downloadcenter.intel.com/download/30196/Intel-Graphics-Driver-for-Windows-15-40-
direct link: https://downloadmirror.intel.com/30196/a08/win64_15.40.5171.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

Since your iGPU has driver bugs, you may also need to turn off Accurate Multiplication in the Advanced graphics settings in Citra configuration.

Enable Hardware Renderer as well in the Advanced graphics settings in Citra configuration.

Hello, sorry for not having responded, you were right, now the games are already fluid, thank you very much!

1 Like