Error when i open a game

https://pastebin.com/GV7Kwc0L

Pls help and thank u!

[ 5.507610] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:488: GL_VERSION: 3.1.0 - Build 9.17.10.4229
[ 5.507647] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:490: GL_RENDERER: Intel® HD Graphics 3000

Citra requires a GPU that supports OpenGL 3.3. Yours only supports 3.1.

and how do i get the open gl 3.3

It depends on your GPU. If you are on a desktop, you can buy a dedicated GPU that supports OpenGL 3.3 at a later date.

so basically i need a better computer to use citra?

If you are on desktop, you can just buy a dedicated GPU i.e. upgrade. If you are on laptop, then you can’t upgrade and will need a new PC.

im on laptop so i guees i cant xD anyway thank u for the help