Error when starting Kid Icarus Uprising

When I start the game, the swirling loading circle appears as normal, but it never ends, and the console gets bombarded with these messages. Also im new to this so can you explain it like you were talking to a child

System Information
Windows 10 64 Bit
I5 3330 3 GHZ
AMD Radeon R9 290x
Citra Nightly | HEAD - 5b0d326
Kid Icarus: Uprising

Log: (Isnt the full log but the full log was incredibly long)
[ 89.099959] Service core/hle/service/service.cpp:HandleSyncRequest:96: unknown / unimplemented function ‘OpenAndRead’: port=cecd:u, cmd_buff[1]=0x60, cmd_buff[2]=0x30000, cmd_buff[3]=0x2, cmd_buff[4]=0x12, cmd_buff[5]=0x20, cmd_buff[6]=0x0, cmd_buff[7]=0x60C, cmd_buff[8]=0xE014D28
[ 89.101063] Service.NDM core/hle/service/ndm/ndm.cpp:ResumeDaemons:104: (STUBBED) daemon_bit_mask=0x0000000F
[ 89.101917] Service core/hle/service/service.cpp:HandleSyncRequest:96: unknown / unimplemented function ‘0x000900C2’: port=cecd:u, cmd_buff[1]=0x0, cmd_buff[2]=0x0, cmd_buff[3]=0x5, cmd_buff[4]=0xA, cmd_buff[5]=0x0
[ 89.102766] Service.NDM core/hle/service/ndm/ndm.cpp:SuspendDaemons:89: (STUBBED) daemon_bit_mask=0x0000000E
[ 89.126866] Service core/hle/service/service.cpp:HandleSyncRequest:96: unknown / unimplemented function ‘OpenAndRead’: port=cecd:u, cmd_buff[1]=0x60, cmd_buff[2]=0x30000, cmd_buff[3]=0x2, cmd_buff[4]=0x12, cmd_buff[5]=0x20, cmd_buff[6]=0x0, cmd_buff[7]=0x60C, cmd_buff[8]=0xE014D28

1 Like

I think it’s a known issue. Check the game compatibility list, will you?

1 Like

I have, but the last update was in July 2017, and i’ve seen people run it pretty well with citra

Yes. that’s an unofficial branch by @mailwl . See the issue I linked.

ghost supplied the link.
However, we don’t support unofficial builds.

you should use the latest build of the citra emu. that might fix the issue

1 Like

@Magic_T
I have the latest canary and nightly builds and can confirm that the issue is still there.

That was the first thing I did lol I actually saw some gameplay footage on youtube of people who got it running but they attached sketchy download links to their videos. I checked the game compatibility list, it’s known to have that error. From what I’ve read it looks like some users have found a work around. If you hear of anyone who managed to find a solution, would you mind pointing me their way? :sweat_smile: I would really appreciate it!