Etrian Odyssey V Mapping Issue


#1

Issue:
When I zoom in to draw my map in Etrian Odyssey V, I’m blocked by this weird black rectangle (as shown in the screenshot), with the map in the background so faded that it’s almost impossible to see.

System Information

  • Operating System: Windows 10
  • CPU: Intel Core i5-7200U
  • GPU: Intel HD Graphics 620
  • Citra Version: Citra Nightly 1189
  • Game: Etrian Odyssey V
  • Screenshot of Issue:

Diagnostic Log
citra_log.txt (41.6 KB)


#2

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

#3

Try enabling/disabling 'Accurate Multiplication` and/or ‘Accurate Geometry Shader’, or disable ‘Enable Hardware Shader’.


#4

Thanks for the reply!

Disabling Hardware Shader (though disabling Accurate Multiplication and Accurate Geometry Shader does nothing) seems to fix the issue. However, this unfortunately means slight slow-downs to the game in order for me to properly map a dungeon. Would you happen to know if the Citra team is planning to improve the Hardware Shader, or is it just a problem with my graphics card?


#5

Try update your drivers: https://downloadcenter.intel.com/download/28515/Intel-Graphics-Driver-for-Windows-10?product=95443


#6

Soz for the late reply.
I’ve already checked my drivers, and they are unfortunately up to date. I think Intel GPU’s are just bad in general ;-;.


#7

Launch the game again, reproduce the issue, close citra and upload your log again.


#8

TBH, the game is still playable with hardware shader off. I’ve tried Citra with Etrian Odyssey Nexus as well, and the same problem persists, unfortunately, which is also fixed by turning hardware shader off. I’ve kinda given up now, and resigned myself to either play without a proper map or play the game at 70-80% speed. Thanks for all you help though!