Failed to save the game Pokémon Alpha Sapphire

Issue:
So i recently started streaming Shiny hunting on Pokemon Alpha Sapphire on twitch. Due to me not having the funds to pay for a caputre card, i decided to extract my save file from the cartridge and run it via Citra. This worked perfectly fine and made for a good stream.

However when i ended it and tried to save the game through the ingame save option, i got the message saying “failed to save the game”. I looked around the internet and it said that I needed to update my drivers, i spend the last hour or so going through all my drivers and updating them. This resulted in nothing however and I am kinda lost on ways to figuere this out, because the excisting threads aren’t of much use to me.

I am currently using the Save state option in Citra, which is perfectly fine, but i would love to eventually transfer back the save file onto the cartridge, so i can transfer the obtained shinies through Pokémon home. I know i could use PKHex to gen these Pokémon into my save file, using the data provided by the files ingame, but i would prefer if i could just transfer the entire save file over.

My two main questions are: Is there a fix to the failed save error? If this isn’t the case, is there a way to convert a save state into a “main” file that is transferable onto a cartridge?

Thanks in advance!

System Information

  • Operating System: Microsoft Windows 10 Home
  • CPU: Processor Intel® Core™ i5-7200U CPU @ 2.50GHz, 2712 MHz, 2 core('s), 4 logische processor
  • GPU: intel ® HD Graphics 620
  • Citra Version (found in title bar): Citra Nightly 1584
  • Game: Pokémn Alpha Sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (38.6 KB)

System Information for Support

Client Version                                Nightly 1584 HEAD-910cc9e
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i5-7200U CPU @ 2.50GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 620
GPU Driver Version                            26.20.100.7325
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [ ]
System Region                                 2
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

how can i enable accurate multiplication?

you can turn it on in emulation then configure then graphics and then advanced and there you will got the option to turn it on

1 Like

your framelimit is in 0… and it is better to use resolution factor as Native(400x240) your’s in 2xNative(800x480)…

1 Like