Fatal Error but the game was running fine before

When game loaded it said fatal error

So I was playing Tomodachi Life earlier today, it was fine, everything was running smoothly. I went to launch the game a few hour later and now every time I go to start it, it gives me a fatal error. I have tried restarting my PC, reinstalling citra, redownloading the game files fresh. It still does the same thing. It was working before and I have changed nothing except the CPU overclocking speed to 175 percent. I even brought that back down to 100. Still nothing. I have the file log here, and will be attaching it to this report. I have not tried any other game but this is the one i need the most seeing as how i was in the middle of a YouTube series on it.

System Information

  • Operating System: Windows 10 Pro
  • CPU: Intel® Core™ i5-4310U CPU @ 2.00GHz 2.60 GHz
  • GPU: Intel HD Graphics
  • Citra Version (found in title bar): 1678
  • Game: Tomodachi Life
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping. citra_log.txt.old.txt (4.8 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

I did not find anything wrong in your log file. Please wait for a moderator to assist.

As a note: when I said “redownloading” I saved a copy of my game files from my 3ds to Google Drive before i started using the emulator so in case i needed to start fresh. No pirating involved.

It looks like you accidentally reopened Citra before uploading the log. The log gets cleared every time you open Citra. Have the log folder open in the background first before closing Citra then immediately upload a new log.

https://drive.google.com/file/d/1m9O_EH5iO42t2Tf6uErGyEElx_WPa0vt/view?usp=sharing
This is the new log, I did what you said.

Core_CPUClockPercentage: 175

Change this back to 100%, you find the setting in the System tab in Citra configuration.

GL_VERSION: 3.3.0 - Build 20.19.15.4835

This driver is outdated, you need to update.

Download win64_15.40.47.5166.zip from https://downloadcenter.intel.com/download/29971/Intel-Graphics-Driver-for-Windows-15-40-
direct link: https://downloadmirror.intel.com/29971/a08/win64_15.40.47.5166.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/

You also have a lot of memory read/write errors which are a sign of a corrupted rom. Redump the game using the guides below. Have at least 4GB free space on your Nintendo 3DS’s SD card:


Thank you I will try this when I get home

I have installed the above driver, and turned it down to 100% i still am having an error. I have redumped the rom and nothing is working.

Its only this game by the way

Upload a new log please.

https://drive.google.com/file/d/1grqlCnRzLvE900ErIj_kNbvd8toacxAN/view?usp=sharing
New log

Service.FS <Warning> core/file_sys/archive_selfncch.cpp:Register:260: Could not read program id when registering with SelfNCCH, this might be a 3dsx file
Core <Error> core/core.cpp:Load:308: Failed to find title id for ROM (Error 0)

Are you sure the game is in .3ds or .cxi format? Are you using any kind of .3dsx file?

Im using a .cxi file for the game.

I am using a .3dsx file for a error fix tho

Yeah, that is the problem right there. Delete it, the game doesn’t need any 3dsx file. iirc this file is something pirates came up with, I give you the benefit of the doubt that you did not download the game from a website.

To make it clear, The game itself is a .cxi file, but i have to launch a .3dsx file first for an error fix.

Okay will do, i heard i needed it but i guess i dont. Thanks for the clear up

Yeah, I can confirm that Tomodachi Life works as is. I recorded a video to report an issue a few weeks ago: https://github.com/citra-emu/citra/issues/5674