FE Echoes battle sprites blur after using states

Issue:
I’ve been playing Shadows of Valentia and have been trying to find a solution for this for a few days now. The sprites have a weird issue with blurring, typically when I save/load a state. The blur is only there when a unit is idle it seems, as the sprites seem to properly display when moving units or viewing these sprites in any other menu. Can I stop this blurring somehow? I’m using a custom screen layout currently (I like having a larger bottom screen) but other than that my citra build is completely vanilla. I accept that Fire Emblem games on citra typically have a few graphical glitches but for some reason this one’s annoying me so any help is appreciated.

System Information

Diagnostic Log
citra_log.txt (138.0 KB)

System Information for Support

Client Version                               Nightly 1766   HEAD-a6e7a81
Operating System                             Windows 10 (10.0)
CPU                                          AMD Ryzen 7 3700X 8-Core Processor              | AVX2 | FMA
Graphics API                                 OpenGL 3.3.0
Graphics Renderer                            NVIDIA GeForce RTX 2070 SUPER/PCIe/SSE2
GPU Driver Version                           512.95
CPU JIT                                      [x]
Hardware Renderer                            [x]
Hardware Shader                              [x]
Hardware Shader, Accurate Multiplication     [ ]
Shader JIT                                   [ ]
System Region                                -1
Shader Disk Cache                            [ ]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

That doesn’t help unfortunately. I have the game running in 8x native as well. The blur is less noticeable at native but looking at the game in native is like squinting at a pile of crumbs anyway.

Put that back down to 4x, having the internal resolution so high will be causing this to be more noticeable.