FE Fates running great until after I load a save file

Issue:
The intro and title sequence run at 100% speed, but as soon as a cutscene plays where 3D models appear, the game goes down to 10% and it carries over to non 3D gameplay.

System Information

  • Operating System: Windows 10

  • CPU: AMD Ryzen 5 3600 6-Core Processor

  • GPU: Radeon RX 580 Series

  • Citra Version (found in title bar): Citra Nightly

  • Game: Fire Emblem Fates Conquest

Diagnostic Log
citra_log.txt (91.8 KB)

System Information for Support

Client Version                                Nightly 1737 HEAD-28039d3
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 3600 6-Core Processor               | AVX2 | FMA
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 580 Series
GPU Driver Version                            21.12.1 30.0.14011.3017
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.

This might be FMV related. Try going to Emulation>Configuration>System and underclock the CPU Clock Speed here to around 75% to see if that has an impact on performance. Keep in mind that this also makes the emulation more unstable, so if you start experiencing freezing, set it back to 100%.

Additionally, you can try to disable Hardware Shaders in Emulation>Configuration>Graphics>Advanced Tab. This sometimes improves performance for AMD GPU users.

It’s running a lot better now with the Hardware Shaders off. Thanks a bunch.