Fire Emblem Awakening Graphic Glitch

Issue:
My Fire Emblem Awakening is graphically flawed when it comes to seeing the place where the characters can move and this is very disruptive to the game. If you disable the “Enable hardware Sharder” option the glich disappears, but the game gets much slower it is bad to be played.

System Information

  • Operating System: Windows 10
  • CPU: i3-5005U
  • GPU: Intel HD Graphics 55000
  • Citra Version (found in title bar): Citra Nightly 1160
  • Game: Fire Emblem Awakening

citra_log.txt (94.8 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Please use the latest Nightly build found here: https://github.com/citra-emu/citra-nightly/commit/eabc972

Other than that make sure your drivers are up to date.

Can you provide settings you are using in hardware emulation mode?

This glitch only happens with this fire emblem, so I guess it’s not on my computer.

Hardware shaders being broken is very likely an issue caused by your GPU model. There’s not much that can be done here.

It’s sad, but thanks for the response.

Your drivers are very outdated(they are from 2016), update them here: https://downloadcenter.intel.com/download/28163/Intel-Graphics-Driver-for-Windows-15-40-?product=84695

Since you are on a laptop you will most likely need to download the .zip version then follow: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/ to install it.

Did not work but thank you

Can you upload a new log file?

citra_log.txt (100.5 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hm, one final thing you can test is to check if Nightly-860 doesn’t have it but Nightly-861 does. If that is the case then Intel HD 5500 is one of the GPUs that benefited from the AMD hack.


I just ran into this issue and Nightly 860 doesn’t have the glitch, so I guess the AMD hack does have an influence on it.
EDIT: For anyone else having this problem, for some odd reason turning on the danger area fixes the glitch, no idea why o.o

Hi friend, that’s how I solved this glitch problem

I always play with danger zones on by pressing the x input (z key by default) and it instantly fixes the graphical glitch on the tiles somehow. If you want to play with hardware shader on, I think it is a good idea to turn on danger zone which is also helpful in actually playing the game as well.

1 Like