Fire Emblem Awakening Paralogue 17 Graphical Bug


In this particular part of the game, the battle map seems to be glitched out by showing black background. This hadn’t happened on any other maps in the game. The glitch does not exist though when I set the backend renderer to software mode.

Is this a known bug already?

System Information

  • Operating System: Windows 10
  • CPU: i5-3470
  • GPU: Nvidia GTX670
  • Citra Version: Canary | HEAD-66312b5
  • Game: Fire Emblem Awakening
  • Screenshot of Issue:


Software (What it’s supposed to look like I guess):

Does this happen with Shader Emulation set to CPU?

Yeah it does. I still able to finish the game though seeing its only a sidequest chapter, but it yeah, pretty weird.

Can you test this on the latest Nightly?

Just tested on nightly and it’s the same, it goes black when hardware renderer is enabled.

Just a guess, can you test this on Nightly-571? It’s the Nightly build before the texture cache rewrite was merged.

Just tried it, yeah same story here.

That’s really strange. Could you please bisect the last working Nightly build by following this post? You can find all of the releases here. (MinGW)

Heya, finally got around to test with previous builds (up to nightly-2) and as far as I can tell that the the glitch always present on this particular map with hardware renderer enabled.

In that case, add this to the issue tracker. Provide the full log using this guide with the latest Nightly. Also post your save file to help reproduce this.

This is due to cubemap textures being unimplemented in the hardware renderer, @fizawira try with this build from PR #3497

@Leo121 Will do.

@BreadFish64 Just tried with that build and it occured there too.

really? can I get a log file from that build?