Fire Emblem Awakening won't play in the latest build, it said that 'shader not linked'


#1

Issue:
Hey everyone,
I tried opening Fire Emblem Awakening on Citra’s latest build but it didn’t work. I believe it said that ‘shader not linked’. I’ve searched all over this forum and the github one but can’t find anything relevant to this issue. Dream Drop Distance won’t work either. Tried it on a Windows 10 PC and it works perfectly fine, but not in mine. Hope someone can help me, thanks in advance! I think I got everything checked, as well.

System Information

  • Operating System: Windows 7 Ultimate
  • CPU: Intel® Core™ i3-3217U CPU @ 1.80GHz
  • GPU: Intel® HD Graphics 4000
  • Citra Version (found in titlebar): 6a72bd6
  • Game: Fire Emblem: Awakening
  • Screenshot of Issue (include the full Citra window including titlebar):

Log:
[ 0.000001] Frontend citra_qt\main.cpp:GMainWindow::BootGame:373: Citra starting…
qt.qpa.gl: Unable to disable rotation.
[ 0.226694] Service.APT core\hle\service\apt\apt.cpp:Service::APT::Init:673: Unable to load shared font: C:\Users\Asus\AppData\Roaming/Citra/sysdata/shared_font.bin
[ 0.227509] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cpp:RendererOpenGL::Init:490: GL_VERSION: 3.3.0 - Build 8.15.10.2761
[ 0.227554] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cpp:RendererOpenGL::Init:491: GL_VENDOR: Intel
[ 0.227737] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cpp:RendererOpenGL::Init:492: GL_RENDERER: Intel® HD Graphics 4000
[ 0.313619] Loader core\loader\ncch.cpp:Loader::AppLoader_NCCH::Load:340: Program ID: 000400000009F100
[ 0.358819] Loader core\hle\kernel\process.cpp:Kernel::Process::ParseKernelCaps:99: ExHeader kernel version: 2.32
[ 0.359682] Service.CFG core\hle\service\cfg\cfg.cpp:Service::CFG::SetPreferredRegionCode:599: Preferred region code set to 2
[ 0.725459] Service.SRV core\hle\service\srv.cpp:Service::SRV::RegisterClient:40: (STUBBED) called
[ 0.726131] Service.SRV core\hle\service\srv.cpp:Service::SRV::EnableNotification:64: (STUBBED) called
[ 0.729648] Service.APT core\hle\service\apt\apt.cpp:Service::APT::GetLockHandle:120: (STUBBED) called handle=0x00038009 applet_attributes=0x00000000
[ 0.734631] Service.NDM core\hle\service\ndm\ndm.cpp:Service::NDM::OverrideDefaultDaemons:201: (STUBBED) default_daemon_bit_mask=0x0000000F
[ 0.734920] Service.NDM core\hle\service\ndm\ndm.cpp:Service::NDM::SuspendDaemons:87: (STUBBED) daemon_bit_mask=0x00000009
[ 0.735521] Service.APT core\hle\service\apt\apt.cpp:Service::APT::Enable:129: (STUBBED) called attributes=0x00000000
[ 0.737435] Service.APT core\hle\service\apt\apt.cpp:Service::APT::GlanceParameter:268: called app_id=0x00000300, buffer_size=0x00001000
[ 0.739385] Service.APT core\hle\service\apt\apt.cpp:Service::APT::NotifyToWait:102: (STUBBED) app_id=768
[ 0.741616] Service.APT core\hle\service\apt\apt.cpp:Service::APT::ReceiveParameter:238: called app_id=0x00000300, buffer_size=0x00001000
[ 0.744027] Service.APT core\hle\service\apt\apt.cpp:Service::APT::AppletUtility:344: (STUBBED) called command=0x00000007, input_size=0x00000004, output_size=0x00000001, input_addr=0x0FFFFF30, output_addr=0x0FFFFEFC
[ 0.744651] Service.APT core\hle\service\apt\apt.cpp:Service::APT::AppletUtility:344: (STUBBED) called command=0x00000004, input_size=0x00000001, output_size=0x00000001, input_addr=0x0FFFFEF8, output_addr=0x0FFFFEFC
[ 0.745671] Service.APT core\hle\service\apt\apt.cpp:Service::APT::SetAppCpuTimeLimit:359: (STUBBED) called cpu_percent=30, value=1
[ 0.751039] Service.APT core\hle\service\apt\apt.cpp:Service::APT::AppletUtility:344: (STUBBED) called command=0x00000004, input_size=0x00000001, output_size=0x00000001, input_addr=0x0FFFFF70, output_addr=0x0FFFFF74
[ 0.754835] Service.FS core\hle\service\fs\fs_user.cpp:Service::FS::InitializeWithSdkVersion:801: (STUBBED) called, version: 0x030300C8
[ 0.844727] Service.GSP core\hle\service\gsp_gpu.cpp:Service::GSP::AcquireRight:692: called
[ 0.845837] Service.GSP core\hle\service\gsp_gpu.cpp:Service::GSP::RegisterInterruptRelayQueue:386: called, flags=0x00000001
[ 1.255501] Service.FS core\hle\service\fs\fs_user.cpp:Service::FS::OpenArchive:457: failed to get a handle for archive archive_id=0x00000004 archive_path=[Empty]
[ 1.257504] Service.BOSS core\hle\service\boss\boss.cpp:Service::BOSS::InitializeSession:39: (STUBBED) unk_param=0x0000000000000000, translation=0x00000020, unk_param4=0x00000000
[ 1.265029] Service.FS core\hle\service\fs\fs_user.cpp:Service::FS::OpenFileDirectly:133: failed to get a handle for archive archive_id=0x2345678A archive_path=[Binary: 02030100db00040000ffffff01000000]
[ 1.267289] Service core\hle\service\service.cpp:Service::Interface::HandleSyncRequest:95: unknown / u


#2

You need to dump your home folder from your 3DS.


#3

to run this emulator you need a original 3ds first,read the faq about how to dump your home folder,and put it in your Citra folder


#4

The “shader not linked” in the log sounds like it might be graphics related which is weird cause I’ve never seen that before. Also the log that is pasted is truncated and doesn’t give the full log.


#5

Indeed, it looks like a graphics issue; a failure to compile and link the shader programs generated by Citra.

If it works on another computer, it likely due to your graphics drivers not being up to date.

Consider updating your drivers: