Fire emblem chapter 1 fire glitch


#1

Hello, I have just started using citra and tried to play fire emblem awakening. But after playing the prologue, and entering chapter 1. The screen turns all red and glitches and I cannot see the characters. Is there any guide to resolve this problem?


#2

GS related, use bleeding 86 to fix the issue for now


#3

I’m afraid this can’t be helped; since I have downloaded the latest version of bleeding edge and the orange upper screen (and later the green screen when I moved on to chapter 2) was still there, blocking my vision.


#4

I got the same problem pls help us :frowning:


#5

Either get a Bleeding Edge build before the 90th one, so that the problem doesn’t bother both of you, or wait until the person who is working on the Geometry Shaders branch gets back to work and finishes it.


#6

As a Mac user, what file do I download and run on the previous bleeding edge release github link? Having the same problem with GS.


#8

you can download bleeding edge 86 or before that, use terminal to compile source code on your Mac OS


#9

If I use the latest nightly build, there are artifacts on screen where there is supposed to be fire/smoke

If I use bleeding edge 86, the former problem is solved but the game crashes frequently to the point of being unplayable

what’s another viable version?


#10

try disabling shader JIT. fixes the crashing for fates at least, which is similiar enough a game that the same fix should work for awakening.

if that fails, you could try 42. but it will run significantly slower (especially cutscences)


#11

disabling the jit shader makes the game suffer from slowdown in the battle screen. BE 42 seems to be doing the trick.


#14

Is anyone aware of any further information regarding updates to the geometry Geometry Shaders? Latest versions of citra are running the game quite smoothly at the moment which is exciting, however this one issue is difficult to play around enjoyably


#15

The latest news is recent changes in citra make the old code completely incompatible, meaning it needs a rewrite. And the person who wrote the code is not around right now to do it. They said they are really busy but might have time eventually to fix it up.


#16

can’t wait for that , hope the person who wrote the code come back soon, BE 86 run FE:A smoothly on my PC , the problem is the game always crash, and the alternative right now is BE 42 which run bit slow but still playable, while FE:Fates you can use the latest build without worrying about gs glitch and crash which make me happy :smiley:


#17

Just to let you know what this actually looks like:


#18

That’s an unofficial build, so it may perform different than the Bleeding Edge builds.


#19

sigh

Happy now?


#20

Reporting the same isssue here, and some testing shows that disabling the JIT shader slows the game down too much for it to be playable, although I haven’t experienced any glitches or graphical errors. Bleeding Edge 86 remedies the graphical issue, however, it crashes barely a minute into loading the game. BE 42 I’m afraid is simply too slow for my poor GTX 580 to handle :stuck_out_tongue:


I’ve also noticed that with the current ‘stable’ version of Citra (Used in the screenshot), certain particle effects disappear entirely, such as the sparkles over an Event Tile. I hope the good folks working on Citra can fix this soon enough, because they’ve been doing a fantastic job so far! Despite my so-so graphical power I get a fair 25-30 FPS during combat cutscenes, whilst grid navigation and low-intensity screens are a solid 60 FPS. Cinematic cutscenes even manage an enjoyable 40-45 or so.


#21

Well, I just thought that I would point that out to save a headache for people using the official builds.


#22

When JayFoxRox returns, work on the GS refactor branch will likely resume, which are the changes behind particle rendering related effects.


#23

Good to know, thanks. 'Cause right now, as others seem to have found out already, we’ve reached a dead end for the time being.