Fire emblem chapter 1 fire glitch


#26

@Nguyen_Duy_Hy Your issue is not the same as this. I’ve told you before to open a new topic and fill out the template. Also your issue might be solved by searching the forum or FAQ.


#27

So, how will we know when or on which version this is fixed?

I played through (tediously, using the mini-map or using the bleeding edge 86 and 80-something that crash constantly) the first 3 chapters with this glitch and found out it happens also on chapter 5 and 7 so far and the paralogue 2.
Tried 42 but it didn’t load the save file so gave up, lazy to restart.

Basically I wanna know how we can tell if it’s fixed or not. I’m new using citra, don’t know how they handle updates.


#28

It’s done when it’s done. I guess enough people will report about it being fixed once it actually happens.


#29

Alright thanks, like I said new on using citra and whatnot, haven’t used emulators in years, have shit knowledge about it all.
Just wanted to know more or less if there’s patch notes around but I’ll keep some bookmarks here and elsewhere


#30

theres no patch notes or anything similar because no one wants to write them. if you or someone you know is interested, speak up please. citra could really use someone who writes articles and loves emulation


#31

Use bleeding edge build 86 but disable Shaders JIT , that permanently fixes the crashing

the problem is it’s a lot slower but still very much playable. I’d advise skipping cutscenes on the 86 ( as they’re really slow) and instead watch cutscenes on the latest bleeding edge/nightly build and then load up the 86 to play

It ain’t perfect but at least you can play the game with a screen instead of using the mini-map


#32

so, I would have questioned how up to date all this thread is but I see it says the last post was made a day ago…

so that leads me to believe I am just not seeing something right.

you guys say build 86 but I see "

"bleeding-edge-239

@citrabot citrabot released this 9 days ago

Build number 239"

so… which one is build 86? am I literally going all the way back to 86 out of 239? or…???


#33

Build 86 is… Build 86 (that you can find here https://github.com/citra-emu/citra-bleeding-edge/releases?after=bleeding-edge-102). The reason was already explained in this topic.


#34

you totally misunderstood, but the link helped regardless.


#35

The best solution that I’ve found so far is to use citra bleeding edge build 86 and TURN OFF shader JIT in the graphics settings. If you don’t turn it off, the game will crash about every 5 minutes into battles. I’ve found that usually the game won’t crash during cutscenes so I usually turn shader JIT back on during them since it’ll boost your FPS significantly, but just don’t forget to turn them off in the next chapter and safe often.


#36

For the fire glitch, the issue can easily be solved by downloading Citra Bleeding Edge 86, and then enabling audio stretching. The main culprit for crashes in Citra Edge 86 is the fact that audio loop buffers are not enabled, in which the program terminates due to not being able to enforce an audio stretch. Thus, the best way to resolve this is to go to “Audio” and enable audio stretching. While it will make the game sound terrible, it also allows you to play most games for hours (my computer’s processor is not ideal, so I sometimes experience crashes, though particularly in Fire Emblem Fates.) So far, I have been able to play through Awakening without a single crash, however.


#37

I have audio stretch enable and my comp muted but I still get crashes… and I have a good system.


#38

I’m close to finishing the game now and its perfectly playable only a few stages will need bleeding edge 86 for all the others use the newest one I haven’t experience any crash in any version.

As an advice use internal resolution 2x is the one that looks better all the other ones even 10x looks too pixelated


#39

how are you going to mark this resolved when its not?

a work around is nice and all but its not suppose to be a ‘solution’.


#40

This is not the issue tracker that developers use. On the issue tracker, any of the issues related to unimplemented geometry shaders are still open. I’m guessing the person who asked this question felt like their issue was resolved and marked it as the solution. I personally think its fine to include workarounds as “solutions” on the forums, as long as theres an actual issue tracker which tracks the bug (and doesn’t count work arounds as solutions.)


#42

ty so much ! i cant play the game by the bugs in the map :frowning:


#43

FWI The problem is not present in the majority of the maps and the game is fully playable ,most times. I played and finished it.