Fire Emblem Conquest on 2500U and Vega 8

Hello! So i have 2 laptops, one with a I5-8250U and another with 2500U and Vega 8. I played Conquest no problem on my I5 and then i wanted to try my other laptop cause i think it has a better GPU, but then game wont even launch, it just stays on black screen.

Is that a Citra problem with Vega 8/AMD or i need to change something? I tried with Accurate Multiplicacion, but nothing.

Any solution? Thanks

System Information

  • Operating System: Windows
  • CPU: Ryzen 2500U
  • GPU: Vega 8
  • Citra Version (found in title bar): Canary1580
  • Game: Fire Emblem Conquest
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

It says the file is too big, so here is the link:

I just let the game run for a while cause nothing happens.

Any help? Just making sure the file can be seen, cause the automod doesnt respond. Thanks

You have a lot of memory read errors, try change region in Citra to match the game. If that doesn’t help then your rom is corrupted and you should redump it. Make sure you have enough free space on your SD card, preferably 4GB. Follow the guides below to redump:


Thank you so much, it was the region, i just selected USA and it worked. Have a great day!

1 Like