Fire Emblem Echoes Character icons become pixelized

I played Fire Emblem Echoes last night, and I noticed my character icons started to become pixelized. I noticed this issue happened after I downloaded the Citra Canary 2485 update.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 5 5600X 6-Core
  • GPU: AMD Radeon RX 5700 XT
  • Citra Version (found in title bar): Citra canary 2485
  • Game: Fire Emblem Echoes: Shadows of Valentia
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (314.5 KB)

In order to save a copy of the log, follow this guide:

Same problem here, i was trying to fix this for hours today.

Thought that i did something with graphics settings that messed things up, or that save files were corrupted… Finally i installed the nightly version of citra and can continue to play :melting_face:

Did the issue pop up after the Citra Canary 2485 update? I noticed the problem almost immediately and have played for about 30 hours without this problem.

I noticed it today and played yesterday without any issues.

Got 40 hours ingame, also i’m using hd custom textures for this game, so tried turning them on and off, etc. but only switching to nightly fixed it for me.

Now the game won’t launch at all, from an update that happened recently. Probably best just to go to nightly for now.

If only using Nightly fixes it, please stick to Nightly. Canary is experimental and fixes will come for this at some point.