Fire Emblem Fates chibi / 3D model issue makes the game unplayable


#1

Issue:
The character miniatures are replaced by gray squares, plus trying to view a character model in 3D makes the screen go dark. It’s still possible to interact with the game, according to the sonds, but it’s not possible to properly play it. Starting from scratch by uninstalling Citra and any vestiges of it also doesn’t help, as in the avatar creation the game freezes with flickering for some odd reason. The game was running perfectly asides from the major known audio bug before a Windows Update.

Excuse me if I fill the following part wrong. I’m not sure if the GPU field is correct.

System Information

  • Operating System: Windows 8
  • CPU: Intel Core i5-4200U CPU @ 1.60 GHz 2.30 GHz
  • GPU: Intel HD Graphics Family
  • Citra Version (found in title bar): 1099
  • Game: Fire Emblem Fates
  • Screenshot of Issue (include the full Citra window including titlebar): https://imgur.com/a/A3fbaa3

Diagnostic Log
citra_log.txt (40.9 KB)


#2

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

#3

Download and install the latest available driver for your GPU.


#4

It says there are no software updates available. I’m assuming that means it’s up to date.


#5

You need to download the latest available from intel’s website, quick link for your GPU (choose the right OS version)


#6

None of those are for Windows 8, though. I know the support for W8 got discontinued so I tried updating it to 8.1 using the store, but it fails to do so, it says my computer needs to have been updated by Windows Update, but my computer doesn’t want to update and I Googled for a solution, but for each solution proposed, there was a problem I couldn’t get past.

What I find the oddest is that before I updated (a different update, I don’t know exactly what that was) the computer (because it wouldn’t start without me allowing it to update), Citra and tons other stuff were working just fine. After the update everything became fucky and it doesn’t even allow me to remove it.


#7

Wait a second, I’ll try one of the older ones that still supported W8.


#8

I tried some for W8, some from the newest ones and tried to solve my original problems unrelated to Citra regarding the W8.1 update and the Windows Update, but nothing worked.


#9

You may have to contact your laptop manufacturer for support on how to update your OS, intel doesn’t provide the latest drivers (which are necessary for citra to function correctly) for windows 8.


#10

That sounds reasonable, but in that case, why did my Citra work before updating stuff? I’d played for a long time without that issue.


#11

huh it beats me, maybe you were stuck on an older version up until recently?
you could try nightly-860 as suggested here, which could work even with ‘Enable Hardware Shader’ enabled. but keep in mind that older citra builds aren’t recommended.


#12

Nah, I was updating Citra a lot, was very up to date. Oh well, vacations are coming and I’ll have more time to deal with computer issues then. It’s a bummer I won’t be able to play Fates on the computer for a few weeks, but that’s fine.


#13

Just an update about a thing I found out just now.

I tried logging in Whatsapp Web and it says the last time I had it active, it was on a Windows 8.1, just a few days before the update. Since I only log in Whatsapp Web in my laptop, it means it HAD Windows 8.1, but after the update it went back to Windows 8, somehow. This is really weird, but it explains how I was running Citra before.

How the eff did my Windows de-upgrade after an update? D:<


#14

these services aren’t accurate, the best way to tell is if you had a windows button on the task bar (not present on 8).


#15

I found a way to fix Windows Update (it took so long) and updated my Windows to 8.1 and guess what? Everything is back to normal, and I’m not talking about just Citra. All the interface is just as I remember before the weird update I was forced to do. It’s great, no more worries. Phew.