Fire Emblem Fates Fire Emblem Fates Special Edition running on 50% power during combat scenes

Issue:
My PC can run triple A games perfectly well as a standard gaming PC, yet when I attempt to emulate Fire Emblem Fates using Citra, combat scenes are unbearably slow hardly surpassing 10 FPS at a max of 60% power. Every other part of the game outside the actual part where you get to play runs fine. I have searched all over the internet for a answer but there has been no straight answer for a fix.

I also know my PC is perfectly capable of running games such as Fire Emblem Fates, as I have emulated other nintendo games such as The Legend of Zelda Breath of the Wild.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (792.9 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1377 HEAD-38c81eb
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon (TM) RX 470 Graphics
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have GDB debugging enabled. This will cause Citra not to launch games. This is only intended for debugging purposes and should be disabled in settings.

System Information for Support

Client Version                                Canary 1377 HEAD-38c81eb
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               Radeon (TM) RX 470 Graphics
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
  • You have GDB debugging enabled. This will cause Citra not to launch games. This is only intended for debugging purposes and should be disabled in settings.

Unfortunately AMD has bad OpenGL drivers on Windows. If you had Nvidia it would run much better. You can also try Ubuntu, the drivers are better there for OpenGL.

You can disable animations to make battles faster if you want as a workaround.

I know a guy who had 3x worse performance on i5-6500, R9 390 than my i7-4710MQ, GeForce 840M :stuck_out_tongue:

So you’re saying there is virtually no fix?

Pretty much, but now you have the knowledge that next time you upgrade your graphics card go Nvidia even if you are paying a premium for it. It’s just how it is, AMD seems to only care for DX11, 12 and Vulkan.

Maybe you can pick up a deal second hand, I got a Rog Strix 1070 last year for $300, though now like GTX 1660 Ti is kinda like a 1070(maybe slightly better) but only with 6GB VRAM iirc but it’s GDDR6. RTX 2060 Super(comes with 8GB VRAM now, regular 2060 was only 6GB) and 2070 Super which are coming out next week might be an option too if you have the money - they are $399 and $499 respectively. RX 5700 & 5700 XT are pretty much dead on arrival now(also OpenGL performance probably will still be bad on them since it’s the drivers which is software related).

I talked to a guy yesterday and he upgraded from RX 480 to RTX 2080 and he can finally play Monster Hunter 4 Ultimate at 60fps now which is a demanding game on Citra. He would be fine with any other Nvidia card(my old GTX 680 could run just fine) but I guess he had the money and went pretty big :stuck_out_tongue:

I just find it a bit strange, because I can emulate FE Awakening fine with no problems, but fates won’t seem to work.