Fire Emblem Fates - Instantly skipping bonding


#1

Issue:
Step one, go to the Private Quarters.
Step two, invite an unit in.
Step three, bonding scene starts. Character approaches screen if it’s a high-level support (A or S) first, iirc
Step four, boots the bonding scene. Character says nothing and the bonding instantly fades to white, like it was getting skipped, even if I didn’t press any buttons at all. (maybe a glitch related to the lines/speech, as it seems to happen on the exact moment the character is supposed to say something, and also because characters have slightly different periods of time before it fades to white)

System Information

  • Operating System: Windows 8.1
  • CPU: Intel ® Core™ i3-4150 CPU @ 3.50GHz 3.50 GHz
  • GPU: NVIDIA GeForce GTX 750 Ti
  • Citra Version (found in titlebar): 0.1.239 (Bleeding Edge)
  • Game: Fire Emblem Fates Special Edition, also happens on Birthright.
  • Screenshot of Issue (include the full Citra window including titlebar):
    There’s not a lot to show as it’s literally just like I was skipping the cutscene, even though I didn’t press a thing.

Log:
http://pastebin.com/rhpGKJRv


#2

Please test with Nightly instead of Bleeding Edge and provide the full log from it.


#3

Seems to work ALMOST normally on the Nightly build. When you start a bonding scene, it works (no skipping), but for some reason the games loses all the voicing and the BGM.
Here’s the log:

http://pastebin.com/xJmkDtdZ


#4

[ 34.026061] Audio.DSP audio_core\hle\pipe.cpp:DSP::HLE::PipeWrite:166: pipe_number = 3 unimplemented

Same error happens in Pokemon X/Y, which causes the black screen. I guess you just have to wait for better DSP support for now.


#5

Alright, thanks. Should I expect it to show up in Bleeding Edge first?


#6

This issue is not solved. Also Bleeding Edge has pipe 3 audio merged but nightly doesn’t. I believe the reason you get further in Bleeding Edge is because of pipe 3 audio. IIRC, pipe 3 audio is not fully understood and is the reason why it’s not in the nightly.


#7

Thought solving issues was for the thread and not for the actual problem itself, my bad.
Also I believe you meant the opposite. I get the bonding scene normally in the Nightly version but Bleeding Edge skips it. However, Nightly version has the sound glitch as soon the character attempts to speak.


#8

No, leo121 is correct. https://github.com/citra-emu/citra-bleeding-edge/pull/19 for a little more background behind the mysterious pipe3. Basically when implementing audio, merry decided she wouldn’t look more into how pipe3 works as its probably a lot of work for a small benefit. Its still in bleeding edge because its a super small change that adds a little compatibility and hasn’t been known to break anything. As far as I’m aware, if this is actually an issue related to pipe3, then its the first reported issue for that.


#9

just gonna contribute.

when i go and do a treehouse inviting event, it works a bit fine in the start but when the scene starts, all musics goes away and the next transition that would happen would freeze citra with nan/nan speed.

im playing on the recent nightly build.


#10

That is the same issue as in this thread.


#11

well it seems that this problem might only be present with the PC(player character). and on that topic, has anyone mentioned that some support skips on itself(ie it doesnt have the whole dialogue) and i cant pinpoint which one does that as it seems sakura/Kaze has that for some reason.