Fire Emblem Fates running REALLY slow in combat

Issue:
Enter a description of your issue here, in full detail.

Hello, I recently started playing FE Fates on citra, but when I’start a map, the preparation phase is just to slow (citra run at 12% speed and the sound can tear apart your brain). Is there some ways to make it run better ? I’ve been reeding the forums and here is what I found, “enable Disk Shader Cache, Hardware Shader and Accurate Multiplication”, so tried (not the harware shader because I didn’t found it) but it doesn’t work. I also found these “However since you have Radeon you probably should consider dual booting Linux (e.g Ubuntu) to get a lot more performance.” and these " there have been reports of 2x-3x more performance on like RX 580 in Ubuntu compared to Windows." which was wrote by @tywald. So here is my question, do I’ really need to dual boot to linux (e.g Ubuntu) ? And if someone have already done that can he testifies ?

System Information

  • Operating System: Windows 10 Pro
  • CPU: AMD Ryzen 5 2600 Six-Core Processor
  • GPU: Radeon RX 570 Series
  • Citra Version (found in title bar): Citra Nightly 1629
  • Game: Fire Emblem Fates
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (402.2 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1629 HEAD-1bb2057
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 5 2600 Six-Core Processor            
Graphics API                                  OpenGL 3.3.1
Graphics Renderer                             Radeon RX 570 Series
GPU Driver Version                            20.9.2 27.20.12031.1000
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Due to AMD’s poorly optimized OpenGL driver, you may experience slowdowns.
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Here is one report but with Mario Kart 7 on Ryzen 5 3550H with RX 560X:

I’ve installed Ubuntu and it does wonders ! the game now run between 80% - 100%.

1 Like