Fire Emblem Fates SE Crash


#1

The game crashes with a repeating error message every time I try to load a particular save file that i’ve played on for fairly long, if I start up a new game and create another save file, it works fine

  • Operating System: Windows 10
  • CPU: Pentimum Dual-Core E-5300
  • Citra Version: Citra | head - c04062c
  • Game: Fire Emblem Fates SE
  • Screenshot of Issue (include the full Citra window including titlebar):

Log : https://pastebin.com/fjPzFpgL (note: When i load that save file directly after, the cmd fills with the junk above in the screenshot and keeps going forever


#2

[ 8.645540] Render.OpenGL video_core\renderer_opengl\renderer_opengl.cpp:DebugHandler:483: API PERFORMANCE 131218: Program/shader state performance warning: Fragment Shader is going to be recompiled because the shader key based on GL state mismatches.

Do you have some sort of GL hook program (like MSI Afterburner, Fraps) running with Citra?

Also, I noticed this:

[ 9.069328] Service.FS core\hle\service\fs\fs_user.cpp:Service::FS::OpenFileDirectly:133: failed to get a handle for archive archive_id=0x2345678A archive_path=[Binary: 02030100db00040000ffffff01000000]

This may be a indication that you didn’t dump your home folder from your 3DS.


#3

You seem to be using an outdated build of Citra, by 3 months. I’d suggest updating as well as disabling any 3rd party applications that may interfere with Citra’s performance such as MSI Afterburner, Fraps, Dxtory, etc (as @Hexagon12 has stated as well).


#4

thank you both, ill get back to you after i attempt to fix it


#5

no luck, prior to this, i had MSI afterburner on my computer but have since uninstalled it, I tried dumping my home files but no luck still and lastly i updated my citra to the latest nightly build but still nothing. Is it possible I might have more conflicting programs or maybe I did something wrong trying to fix it?


#6

I have FE Fates SE and it works fine on my end. Would it be possible for you to upload your save for me (or another) to test? I think it’s the “00179800” folder, just upload that. If I or another can get it working we know it’s not the save; if not, then we know the issue lies with the save files themselves.

Here is the file path to the Citra save files:
%appdata%\Citra\sdmc\Nintendo 3DS\00000000000000000000000000000000\00000000000000000000000000000000\title\00040000

That is unless someone else has a better option?


#7

You can find the save by right clicking on the game in the game list and selecting “Open Save Data Location”.


#9

Sorry, I can’t upload folders, how do I give you the save file?

Edit: Nvm here you go: https://www.dropbox.com/sh/hj8lodhec8p7r62/AAA1prtD-6yUMnEuv7UcbvoRa?dl=0


#10

I’m having the exact same issue with the save. I tried running this on the latest “Bleeding Edge”, and using Citra BE 86 which I usually use. On the outdated BE 86 build Citra cashes when you try loading the save, this issue does not happen on the later build. I presume the fault lies with the save and not Citra itself. Sorry I couldn’t be of more help here, I’m not a Citra developer. I’ve also attached my own log file to this post, I hope it helps further diagnose the issue.

What I can do is offer my save. I’m at Chapter 9, same route as you. I’ve also done some grinding and the only A+/S rank social link I’ve done is with Kaze and Rinkah. My protagonist also has the Magick buff and luck debuff chosen at character creation. I’m also on the Normal difficulty with Ironman enabled. Hope it helps :slight_smile:

MY SAVE FILE
MY LOG FILE


Rune Factory 4 - Missing textures/graphics while using an OpenGL v3.3 compatible dedicated legacy GPU
#11

Thanks for help anyways Tibs, I’ll play on that save file for now but I’ll leave this discussion open in case someone has a better idea


#12

try Citra edge build 104. it works well for me on playing fire emblem if(jp ver)