Fire emblem Three houses crashing

So I have yuzu on 2 devices: one with amd gpu and the other one with nvidia. I couldnt even see the throne on the main menu on the amd one, but the nvidia one worked fine so i continued with it. Then id have an unskippable black-screen cutscene, but with sound, then a crash message “yuzu.exe has stopped working”. I dont know if you can help me or my laptop just sucks but i said id ask you about it.
Hope this is the log you want, couldnt find others. This is a lite version of the log bc it was too big (9MB) to upload and i put in it segments that were repeating.
cut_yuzu_log.txt (95.8 KB)

Please zip the log and upload it fully, it will be a lot lighter then.

tried before, said it wont upload zip or rar

https://mega.nz/#!7s0giaRZ!uL9qaz_nvwf70_JhT1fJqV-YakCJOpTTk4oHXS6LSCM
here’s a link with the rar of the log’s full version

It’s the normal bunch of bugs. Wait for improvements on yuzu.
There’s a newer driver for your GPU.

Oh, OK! Thank you for telling me! Imma wait now ^^