[Fix] Dragon Quest 8 Overworld Framerate Issue

Noticed a lot of people having this issue and spent a while looking for a fix. I tried toggling graphics settings and cpu underclocking/overclocking (messing with the cpu just crashed citra for me). This 30fps framerate cap cheat fixed it for me, but I’ll post USA/EU codes as well.

Note: There were 30fps cheats without the L+R but they did not work as well as the L+R codes for my JPN version. Hope this is useful to someone. (Edit: This was using the latest Canary build.)

USA Ver.
[30 FPS v1.0 Press L + R]
282A6FDA 00000000
DD000000 00000300
082A6FDA 001E0000
D2000000 00000000
{After loading the game, press the (L + R) key at the same time.}

EU Ver.
[30 FPS v1.0 Press L + R]
282A6FDA 00000000
DD000000 00000300
082A6FDA 001E0000
D2000000 00000000
{After loading the game, press the (L + R) key at the same time.}

JP Ver.
[30 FPS v1.0 Press L + R]
28270052 00000000
DD000000 00000300
08270052 001E0000
D2000000 00000000
{After loading the game, press the (L + R) key at the same time.}

Credit to reddit user Djdan01. Just wanted to post this here so more people could see the fix.

2 Likes

If anyone is skeptical, I just finished the game using the fix and had no issues. I know sinking 40+ hours into something that might bug out at some point might seem awful, so I wanted to show that it worked (for me, at least).

I also read about some camera bug that stopped progress early in the game. Never ran into that problem. But I also played the JP version.

Anyway, have fun.

1 Like

Man, I don’t know how you guys figure this things out…But it works. Btw, USA version. Thanks.

This worked except that the fast battle speed no longer functions due to it being locked at 30 FPS.

This thread has a code called “60 fps - Press and Hold ZL for 30 fps”. If it was “30 fps and hold ZL for 60” instead, this might fix the problem, but holding ZL with that code applied doesn’t seem to do anything.

I never made that connection regarding fast battle. I cranked up the framerate with a cheat to grind quicker instead LOL.

Glad this post ended up helping people.

I’d like to use 30 FPS on the overworld and 60 FPS in battles though I don’t know how this would be possible without manually inputting the codes every time

Yeah, not sure how you’d get around that. I would boot the game at 60 fps and disable it in areas that I hadn’t been to yet, or if I completed my grinding.