Force OpenGL3.3 on Intel HD Graphics 3000 (Windows)

@TheRedDevil Thanks a lot man. I was finally able to play pokemon Omega on my potato laptop, after losing all my hopes. I can’t explain how happy I am. Thanks a lot man, though I needed to do some steps more to play this. Thanks.

@Smsry I had the same problem as yours. The citra log showed that I had openGL1.1 by microsoft. I searched a lot on Google and found nothing.
Finally found a solution from a video in youtube.
You have to do this:
1.Download Microsoft ADK.
2.While installing it, only tick the “Application Compatibility Tools” in features. We don’t need anything else. Install it.
3. Run it.
4.Click on “Fix.”
5.Write anything on the name and vendor of the program. In location, select “Citra-qt.exe”.
6.Click on Next.
7.Click on Next again.
8.Now in Compatibility fixes, tick on “Win81RTM/VersionLEE” and click on parameters.
9.In module name, type “ig4icd64.dll” and click Add and then OK.
10.Click on Next.
11.Tick all the options and click Finish.
12.Now save the database and right click on it and select Install.

You can now run the citra and check log, where you can see it will be written “OpenGL3.1.”
Follow the steps of @TheRedDevil and you can run Citra on your PC. If you have downloaded latest Mesa, then you donot need to replace any opengl. And yes, in the CMD, i used “yes/y” for all the configuration. This is how I did it, cheers. :grin::slightly_smiling_face:

1 Like

Nice find :grin: I hope this will helps anypne with the OpenGL 1.1.0 issue.

As maintainer of mesa-dist-win on github I noticed reports on difficulties in getting citra working with Mesa3D on windows so I put up a video tutorial here: https://pal1000.github.io/shared/tutorials/citra-mesa3d-windows.mov

I also noticed rapid concern and dismiss of systemwidedeploy.cmd tool as those involved didn’t understand what it exactly does. I hope this video clarifies it.

4 Likes

Wow, I’m never knew one day the dev himself would reply to this article, I’m honored to see you here :grinning:

I see, so the system-wide deployment didn’t replace any system files at all, but for beginners, I think the per-app deployment is enough. Thanks for the suggestion though, I’ll try the system-wide deployment when I get home.
Update: the system-wide deployment worked well, so now there is no need to create symlinks anymore :grin:

Now that there is a video tutorial here, I don’t think I will need to update this thread at all. You guys can follow the video tutorial from pal1000, and if anyone have the Generic OpenGL 1.0 problem, you can follow these steps to see if it works (thanks jebish :grin:):

There is no need to use my old method, just use the one from the video :grin:

1 Like

@TheRedDevil hello, do you mind take a look at my problem ?

For short my problem is about the citra-qt crash(Not Responding) when I start the game, my GPU is intel® HD Graphics 4600 / NVIDIA GEFORCE 940M and my OpenGL version is 4.3

my question is do I need to follow the “Force OpenGL3.3” steps ? or do you have any other solution to solve my problem?
I really need help please, because I want to play it so badly :frowning:
fyi, I’ve tried things like reinstall it but still didn’t work

thanks!

You don’t need to, as your GPU is far better than that of the Sandy Bridge GPUs (in fact yours even support OpenGL 4.6)
I suspect that it was your driver problem - Windows 10 tends to screw up your drivers after any major updates. But before trying to update your drivers, try to disable hardware renderer to see if it works.

@TheRedDevil
okay
I already scan my PC from microsoft’s website to check if my driver is up to date or not
And, the result is that all of my drivers are already in the newest version

already tried to disable the hardware renderer, but still it doesn’t work :frowning:

here’s an update
I’ve created a new user account in my windows 10
And, I install my citra in that user account, and it worked
BUT, after I restarted my PC, it’s back to not responding state

do you have any idea how to fix this?

go to Intel web site for the latest graphics driver or Nvidia web site for the latest graphics driver if you have a Nvidia card installed.

@Takeshineale128 already did, but still doesn’t work… please, is there any solution?

your Intel GPU only support OpenGL 3.1 so your out of luck. you will need a graphic card if ifs a desktop PC or a new laptop if its a laptop.

It doesn’t work in my laptop ( both perappdeploy and systemwidedeploy ). I’m using Intel HD 2000 and Windows 7.

Hey guys, I am back, My computer broke so I cannot do the updated tutorial lately, but I will try it when it’s fixed. Thanks!

Only HD 3000, didn’t you read the title?

please make a complete video on this process


still getting error

Welcome to the community, Bahgya :smiley:

There is one. Not mine, but from the dev of the mesa-dist-win himself:

He used the system-wide deployment, but the steps are mostly the same.
Also, the .bat file should be:
set MESA_GL_VERSION_OVERRIDE=3.3COMPAT
citra-qt.exe
You obviously got it wrong last time, forgetting the “set”:

Yes, i have a same gpu and i can play, but fps is very low

1 Like

I have tried everything is this whole thread and still are not able to run any game in Citra.
My errors in the log are this:

[  35.600039] Service.HTTP <Error> core/hle/service/http_c.cpp:DecryptClCertA:727: ClCertA file missing
[  35.600128] Render.OpenGL <Info> video_core/renderer_opengl/renderer_opengl.cpp:Init:551: GL_VERSION: 3.1.0 - Build 9.17.10.4459
[  35.600232] Render.OpenGL <Info> video_core/renderer_opengl/renderer_opengl.cpp:Init:552: GL_VENDOR: Intel
[  35.600335] Render.OpenGL <Info> video_core/renderer_opengl/renderer_opengl.cpp:Init:553: GL_RENDERER: Intel(R) HD Graphics 3000
[  35.600444] Render <Error> video_core/video_core.cpp:Init:46: initialization failed !
[  35.600510] Core <Critical> core/core.cpp:Load:123: Failed to initialize system (Error 10)!

and then the log ends.

At first it showed GL_Version: 1.1.0 and after i followed the microsoft adk steps i got 3.1.0, then i followed the original steps again, but alas still on 3.1.0.

I’m on Windows 10, Intel HD Graphics 3000, 16GB RAM.

Any help is highly appreciated!


still getting same output :frowning: