Force OpenGL3.3 on Intel HD Graphics 3000 (Windows)


#103

Okay. First of all, calm down, you’re making a scene here, and if I read all this just after I get home from the university, I’ll be just as mad as you were.
Second, you shouldn’t send that kind of screenshot here, because what I need is the log generated by Citra, and I want to see what you’ve added in the citra-qt.bat, as well as the citra’s folder to see if .symlinks are there.
Third, again from your screenshot, I did see a cmd window in the taskbar. You can take a screenshot of it next time.
I’m trying to be civilize here, so I suggest that you should do the same. To be fair though, I understand how you feel, as I only discovered this method a year ago, and I felt left out when I can’t even run anything at all before it.


#104

If it didn’t, then you have failed to link the emulator with the drivers. You can try running the .cmd again, then check the installation folder next time to see what happens.
Also, which version of MESA are you using? I haven’t used MESA for awhile, but the .cmd’s wordings may change.


#105

@TheRedDevil Thanks a lot man. I was finally able to play pokemon Omega on my potato laptop, after losing all my hopes. I can’t explain how happy I am. Thanks a lot man, though I needed to do some steps more to play this. Thanks.

@Smsry I had the same problem as yours. The citra log showed that I had openGL1.1 by microsoft. I searched a lot on Google and found nothing.
Finally found a solution from a video in youtube.
You have to do this:
1.Download Microsoft ADK.
2.While installing it, only tick the “Application Compatibility Tools” in features. We don’t need anything else. Install it.
3. Run it.
4.Click on “Fix.”
5.Write anything on the name and vendor of the program. In location, select “Citra-qt.exe”.
6.Click on Next.
7.Click on Next again.
8.Now in Compatibility fixes, tick on “Win81RTM/VersionLEE” and click on parameters.
9.In module name, type “ig4icd64.dll” and click Add and then OK.
10.Click on Next.
11.Tick all the options and click Finish.
12.Now save the database and right click on it and select Install.

You can now run the citra and check log, where you can see it will be written “OpenGL3.1.”
Follow the steps of @TheRedDevil and you can run Citra on your PC. If you have downloaded latest Mesa, then you donot need to replace any opengl. And yes, in the CMD, i used “yes/y” for all the configuration. This is how I did it, cheers. :grin::slightly_smiling_face:


#106

Nice find :grin: I hope this will helps anypne with the OpenGL 1.1.0 issue.


#107

As maintainer of mesa-dist-win on github I noticed reports on difficulties in getting citra working with Mesa3D on windows so I put up a video tutorial here: https://pal1000.github.io/shared/tutorials/citra-mesa3d-windows.mov

I also noticed rapid concern and dismiss of systemwidedeploy.cmd tool as those involved didn’t understand what it exactly does. I hope this video clarifies it.


#108

Wow, I’m never knew one day the dev himself would reply to this article, I’m honored to see you here :grinning:

I see, so the system-wide deployment didn’t replace any system files at all, but for beginners, I think the per-app deployment is enough. Thanks for the suggestion though, I’ll try the system-wide deployment when I get home.
Update: the system-wide deployment worked well, so now there is no need to create symlinks anymore :grin:


#109

Now that there is a video tutorial here, I don’t think I will need to update this thread at all. You guys can follow the video tutorial from pal1000, and if anyone have the Generic OpenGL 1.0 problem, you can follow these steps to see if it works (thanks jebish :grin:):

There is no need to use my old method, just use the one from the video :grin:


#110

@TheRedDevil hello, do you mind take a look at my problem ?

For short my problem is about the citra-qt crash(Not Responding) when I start the game, my GPU is intel® HD Graphics 4600 / NVIDIA GEFORCE 940M and my OpenGL version is 4.3

my question is do I need to follow the “Force OpenGL3.3” steps ? or do you have any other solution to solve my problem?
I really need help please, because I want to play it so badly :frowning:
fyi, I’ve tried things like reinstall it but still didn’t work

thanks!


#111

You don’t need to, as your GPU is far better than that of the Sandy Bridge GPUs (in fact yours even support OpenGL 4.6)
I suspect that it was your driver problem - Windows 10 tends to screw up your drivers after any major updates. But before trying to update your drivers, try to disable hardware renderer to see if it works.


#112

@TheRedDevil
okay
I already scan my PC from microsoft’s website to check if my driver is up to date or not
And, the result is that all of my drivers are already in the newest version

already tried to disable the hardware renderer, but still it doesn’t work :frowning:

here’s an update
I’ve created a new user account in my windows 10
And, I install my citra in that user account, and it worked
BUT, after I restarted my PC, it’s back to not responding state

do you have any idea how to fix this?


#113

go to Intel web site for the latest graphics driver or Nvidia web site for the latest graphics driver if you have a Nvidia card installed.


#114

@Takeshineale128 already did, but still doesn’t work… please, is there any solution?