Frame Drop Random But Constant

Issue:
Frame drop from 200% to 70% random but constant, when slows down it stays slowed down for long time, then goes back to fast. Not related to anything happening in the game apparently.

System Information

  • Operating System: Windows 7 64 bit
  • CPU: intel i7 2600 3.4 GHz
  • GPU: Nvidia GeForce GTX 650 TI Boost
  • Citra Version (found in title bar): Almost very version
  • Game: Fantasy Life

Log
citra_log.txt (2.8 MB)

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

Can someone explain to me what it means in practice?

Why have you tried playing it with the frames at 100% lock?

Yep. Tried locking/unlocking framerate, disabling/enabling every option, both nightly and canary, run as an admin, clear cache from cmd, formatting the whole fricking pc (windows was kinda corrupted so no big deal but still…).
The game just slows down random. Sometimes goes back to fast for a minute then slows down again indefinitely.
I’m surprised noone seems to care about a problem like this, i found only one thread about a similar problem but it’s completely ignored.

the problem is that there’s no way to tell what is the issue exactly, especially because that would require someone else to reproduce the same issue, and since not a lot of users are complaining about the same issue, it probably means that either the problem is with the user pc (overheating, driver issue, OS, etc) or that the pc simply can’t handle the game at fullspeed.

when you said that the framerate drops randomly, does it mean that if you look or walk to a very specific spot at different times but under the same circumstances (time of day, number of character on screen, character armor, etc) the game will randomly run at, say 70%, and another times at 100%? are you sure that the circumstances under different performance observations are equal?

take a screenshot or record a video if you spot anything like this.

Did you dumped all the files correctly from your 3ds? At some point, your log was saying that was missing the bad word file.

Or trying to dump your game again?

Already checked for overheating and drivers. The slowdowns happen even when I’m not moving and nothing is loading on-screen (at least Apparently), but I noticed that it usually slows down during some loading, like the time changing from morning to noon, or right after the loading of a map, or after an animation with “sparkles” and shiny stuff, but I have to say that all these things have run normally in other occasions, there where times where the emulator just did its job going at 150/220% for hours, that’s why I think it’s some software issue related to citra. I’ll record some footage when i have time tho.

It’s not the game. I used a dump from… A friend … And now i’m using the dump from my 3ds only from 2 days, just to see if the cause was the dump… Right after starting my dump the game was lightning fast, the dlc was installed successfully and I was an happy boy. Then it slowed down again.

i see, these slow downs during these sort of transitions or animations and effects are to be expected, also known as shader compilation which causes these micro-stutters, do you remember on which build you didn’t experience these issues? your browser history could be a good place to find which build you’ve downloaded, etc.

edit: btw, these microsutters occurs less the more powerful the hardware is.

1 Like

Never played that game, but didn’t have any problem like that with other games. Does it happen only with that game?

They are not like microscutters… They happen only once and cause the “permanent” slowdown. If the game is running fast you can’t even see them. The best build was 923 I think, it was always fast but if I install that build now, (clean install ofc, also I already tried it many times) it slows down anyway.

update your GPU driver, try deleting the gpu cache, on nvidia i think is the folder “NV_Cache”, %temp%\NVidia Corporation before launching citra, just a warning that this folder is likely to have other games, so try looking on the Nvidia control panel if there is this option to change, and try creating a profile for your game.

Already tried to change nvidia control panel settings for citra but honestly I can only look at the setting’s description for reference… I’m not an expert. I’ll try erasing the nvidia cache.

For now I only tried final fantasy explorers and it goes 500% on menu and 200/300% in-game (strange, looks like it should be heavier than fantasy life…) but i did not continue to play, I was just testing the dump.

Sounds very much like the Shader compilation was slowed down. @Antonio_Di_Prisco you seem to have some knowledge, so can you try using Microprofile, and send the conditions before & after the slowdowns? I’m sure you’ll find instructions online.

I don’t get how to send conditions… if you can tell me what i need to do it would be easier.

Update: i tried erasing nvidia cache, not working, looks like citra doesn’t even create files there. About microprofile, i see the graphs but no option about exporting/creating a log or something similar so i’m kinda lost. Hoping in some help, thanks.

Just take a screenshot & post it here.

Here it is:
100+% speed, no frame limit

slowing down after moving in a “3D heavier” area, 70-% speed

Massive slowdown (35% speed) right after taking the screenshot of the image above


Last one is the slowdown that i get randomly when playing, but this time is was triggered by me pressing Stamp on the keyboard and it was worst than usual (usual is 50/70%)

I mention again that all the places in-game where the slowdowns occur are capable to running at fast speed, it’s not about processing power. Looks like ARM JIT goes nuts…

1 Like