Freeze when launching patched russian ROM of majora's mask 3D (0%, 0 FPS, nan ms)

Issue:
Enter a description of your issue here, in full detail.

I used the zelda64rus patch on majora’s mask 3D, and when I launch the .cxi the patcher makes I get a freeze on the first frame of the game (the yellow circle with skull kid). The citra app still works, although the dropdown menus are very slow, and trying to stop the emulation or exit the app freezes the entire app completely. I’ve tried all the shader and overclock stuff as well as turning off new 3ds mode and I’m just really confused on what’s going wrong. Launching OoT3D works fine.

System Information

  • Operating System: Windows 10
  • CPU: AMD Ryzen 3 1200 quad-core processor
  • GPU: Nvidia gtx 1070
  • Citra Version (found in title bar): nightly 1717
  • Game: Majora’s Mask 3D Russian patch
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (37.4 KB)

The actual log file goes on for much, much longer, but I had to shorten it because the maximum filesize is 4mb.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1717 HEAD-647a6f8
Operating System                              Windows 10 (10.0)
CPU                                           AMD Ryzen 3 1200 Quad-Core Processor            | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1070/PCIe/SSE2
GPU Driver Version                            432.00
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. Download Drivers | NVIDIA

Updating drivers had same result

We don’t provide support for anything other than commercial games. The patch was clearly at fault here, the log file says much the same (unmapped read spam). So long as the base game runs, out job is done. Ask the patch creator for support with their patch.

Ah, I figured. Thank you.

In case of Russian fan translation of Majora’s Mask 3D set region in Citra settings to Europe, not “Auto”.
Other Russian fan translations of Zelda 3DS games should work fine with “Auto”.

Dude thank you so much. I was literally gonna go crazy over this.

For those interested the region setting is in general > general > region. Now I can practice my favorite language in HD :wink: