Friend cannot connect to room NSMB2

Issue:
Hello, when I create a room and my friend, who isn’t on the same network as me, tries to connec to it, it gives her the " Unable to connect to host" error. We are able to connect together on one of the many already created rooms, but she can’t connect to the room when if it is one I created. I have forwarded the 24872 port on my router for TCP and UDP . I don’t know what I did wrong, so any help is appreciated. Thanks =)

System Information

  • Operating System: Windows 10
  • CPU: Intel® Core™ i5-7200U CPU @ 2.50GHz, 2712 MHz, 2 cœur(s), 4 processeur(s) logique(s)
  • GPU: GeForce 940MX
  • Citra Version : Nightly 1086
  • Game: New Super Mario Bros 2
  • Screenshot of Issue (include the full Citra window including titlebar):

    This is a screenshot of my friend’s screen when she tries to connect to my room.

Here iis a screenshot of the forwarded port for citra :

Diagnostic Log
If needed, I could ask her for her logs too but here are my logs :
citra_log.txt (29.5 KB)

I found some issues in that log that need resolving:

  • Citra is currently utilizing open-source system files which may cause emulation to be less accurate, but not affect system stability.

image

Could this be the problem? 8 & 7 are swapped :stuck_out_tongue:

Well then, so I felt really dumb for a sec :sweat_smile: , so i opened the right port :


Then we tried again but still the same error :frowning_face:

Have you tried to restart your router?

Me too…
When I use [canary-1024] (in fact,this problem has not solved since early August)to connect a room and select to exchange a pokemon or prepare a battle,it can not work fluently .It back to the quondam screen rapidly.
And then I try to use [Valentin’s projected citra] to host it ,it succeeded unexpectedly.
What’s wrong with it?