Friend can't join my multplayer room

Issue:
I created an account so I could create a private multiplayer game for my friend and me, but he’s unable to connect. The error says to check if the server connections are correct, with ports and whatnot. I even did the whole port-fowarding thing on my router and he’s still unable to join

System Information

  • Operating System: Win 10 Pro 64-bit
  • CPU: i5 3470
  • GPU: gtx 1060
  • Citra Version (found in title bar): Nightly 1095
  • Game: ACNL - Welcome amiibocitra_log.txt (269.3 KB)
1 Like

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Can you show how you port forwarded? Double check firewalls as well.


it’s all in german but I guess it’s clear enough

add an exception for citra-qt.exe and citra-room.exe on your antivirus (including windows defender).

Also maybe an exception in the Windows firewall is needed.

why if I check this for multiplayer it always crashes ?? what is it because the emulator or the component is a blank pc?
But if you use a Citra valentine can be multiplayer

I added all three exe files of citra as an exception to my firewall, it still won’t work… Anti-Virus, too

Open the ‘Windows Firewall with Advanced Security’ and click on the ‘Inbound Rules’ tab.
look for citra-qt (there should be two), right click and delete them.

open citra and create a room, a windows firewall message will pop up, click to allow it.
also verify your username and token, tell your friend to do the same thing.

1 Like

I did that, but I also tried re-installing citra and now it won’t let me announce the room. It tells me to “login” in the web-tab of the configuration. The thing is: I did that already and it even gives me the green checkmarks when I verify it

image

image

It also won’t allow me to choose my prefered game anymore, I can’t click it and it shows up just blank

Close citra, delete qt-config.ini (backup if you want to) on C:\Users\%username%\AppData\Roaming\Citra\config, open citra and configure it again.

I did that, now I can pick a preferred game but I still get the error that the room can’t be announced publically, even though I verified my username and cert.

does your antivirus have a firewall? try running citra as admin. can you connect to public rooms with your friend?

no my antivirus does not have a firewall, we are both able to connect to public rooms but we would love to use our own, private rooms

check thee ‘Windows Firewall with Advanced Security’ again, close citra first and delete any entry that has citra on it, both on inbound and outbound. open citra and try to create a room again, the windows firewall alert window should appear with the checkbox ‘Public networks, such…’ already checked, click on ‘Allow access’.

image
still won’t do it, I really don’t know what else to do

check your router firewall, or search online for people with the same router and same problem (port forwarding)

i have the same problem

Hi… me too have the same problem with multiplayer… “Unable to connet to the host…”