Friends cant connect and I cant connect to them

Issue: I create a room and friends cant connect to my room and vice-versa, but we can connect to others rooms. Do i need to do something in Router to open access to fill my room?
Enter a description of your issue here, in full detail.
I create my room and im in my room but no one can connect to it and even my friends creating and i cant enter to their room. Dont know if i need to open more ports to that or not but i tried and same problem.
Thanks for the help :wink:

System Information

  • Operating System: W10 x64
  • CPU: i7-8700K
  • GPU: GTX 1080
  • Citra Version (found in title bar):
  • Game: Pokemon UltraMoon
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide: citra_log.txt (4.0 KB)
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1617 HEAD-b00ed0c
OpenGL Vendor                                 null
OpenGL Renderer                               null
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Hereโ€™s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.
1 Like

Yes, you need to open the port in your router. Here is an example what I have done in mine and I can host no problem.

Since every router is different you will have to find the equivalent on yours. You could try find your router at https://portforward.com/router.htm for general steps how to do it.

Also donโ€™t forget to allow Citra in your firewall for both private & public networks(if you use Windows Firewall).

Thx for the quick response but in my router i have all correct i think but check this image and if u see somethink wrong please notice me.


It is in Portuguese so any word you dont understand please say.

I assume this is your router? It looks very similar at least:

If it is, double check that you are using the correct local IP address. e.g 192.168.1.2 that I had but you have to check what local IP address your computer has been given by the router which you can check in cmd.exe or powershell by typing ipconfig /all.

1 Like

Im testing that but at first try it doesnt worked.