Funky graphics and consistent crash point in Xenoblade Chronicles definitive edition

yuzu_log.txt (884.9 KB)

(spoilers for the seventh party member in screenshots)
xc de has some unusual graphic effects in yuzu, mostly relating to lighting it looks like?



these appear regularly but arent as big a deal as the other graphical mishaps that can be really hard on eyes. it doesnt seem to have much consistency in colour or severity, but i think it happens more when moving into an map with a lot of effects in the air (like satorl marsh)




(these are the same area)

im thinking that these bugs might be a driver thing but even if i went to look i imagine itd all fly over my head and make me cry trying to figure it out jkdfhlfgj
another minor thing is that the map menu β€œdesyncs” the map graphic and messes up its aspect ratio unless you can get all of it on screen at once it seems but i think that is more likely a universal thing that is known about

and also?? the program seg faults whenever i use an art. im a little low energy and dont want to test if there were ways to make it not happen (to help try and deduce what might be causing it), because i thought it might only happen when using arts by the player (not enemy/party arts or auto atakcs)
i tried to make a video that shows off the super special graphics thing and the crash when beating up a poor bat friend

System Information for Support

Client Version                                yuzu Development Build master-mainline-636-4895-g5da33ea9c
Operating System                              Manjaro Linux
CPU                                           AMD Ryzen 5 1600 Six-Core Processor             | AVX2 | FMA
RAM                                           15.64 GB
Pagefile / Swap                               17.21 GB
Graphics API                                  OpenGL ?
Graphics Renderer                             Radeon RX 580 Series (POLARIS10, DRM 3.40.0, 5.10.23-1-MANJARO, LLVM 11.1.0)
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [x]
CPU Accuracy                                  Accurate
GPU Accuracy                                  High

I did not find anything wrong in your log file. Please wait for a moderator to assist.

This recently started to happen on AMD hardware, strangely it affects both Windows and Linux.
How is it with RADV?

,um , like what is radv,

The Linux Vulkan driver that usually comes installed by default. Basically just test Vulkan.

when i try to boot the game in vulkan it seems to crash when it tries to launch, i think this happened in older mainline builds too :frowning: yuzu_log.txt (46.1 KB)

System Information for Support

Client Version                                yuzu Development Build master-mainline-636-4895-g5da33ea9c
Operating System                              Manjaro Linux
CPU                                           AMD Ryzen 5 1600 Six-Core Processor             | AVX2 | FMA
RAM                                           15.64 GB
Pagefile / Swap                               17.21 GB
Graphics API                                  Vulkan 1.2.145
Graphics Renderer                             AMD RADV POLARIS10 (ACO)
GPU Driver Version                            radv 20.3.4
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [x]
CPU Accuracy                                  Accurate
GPU Accuracy                                  High

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                yuzu Development Build master-mainline-636-4895-g5da33ea9c
Operating System                              Manjaro Linux
CPU                                           AMD Ryzen 5 1600 Six-Core Processor             | AVX2 | FMA
RAM                                           15.64 GB
Pagefile / Swap                               17.21 GB
Graphics API                                  Vulkan 1.2.145
Graphics Renderer                             AMD RADV POLARIS10 (ACO)
GPU Driver Version                            radv 20.3.4
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [x]
CPU Accuracy                                  Accurate
GPU Accuracy                                  High

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Can you try with accuracy on normal?

look like it got further !! yuzu_log.txt (49.5 KB)
but it still hit a segmentation fault on launch when building 1(one) shader :sob:

System Information for Support

Client Version                                yuzu Development Build master-mainline-636-4895-g5da33ea9c
Operating System                              Manjaro Linux
CPU                                           AMD Ryzen 5 1600 Six-Core Processor             | AVX2 | FMA
RAM                                           15.64 GB
Pagefile / Swap                               17.21 GB
Graphics API                                  Vulkan 1.2.145
Graphics Renderer                             AMD RADV POLARIS10 (ACO)
GPU Driver Version                            radv 20.3.4
Docked Mode                                   [x]
CPU Multicore                                 [x]
Async GPU                                     [x]
Assembly Shaders                              [ ]
Async Shaders                                 [x]
CPU Accuracy                                  Accurate
GPU Accuracy                                  Normal

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Seems like a Polaris specific bug, RADV can be quite experimental sometimes.

:sob: :sob: :sob: :sob: :sob: dang
hope that the graphical issues get resolved soon then since they are really hard on my eyes. i feel better at least knowing that i didnt just cry into a void about this, which was what i was planning on doing before i remembered i had a citra forum account, thank you for helping!

1 Like