Game crash ultra sun

Issue:
Enter a description of your issue here, in full detail.

pokemon ultra sun crashes on every battle or cutscene. the sound keeps going but the screen freezes and i cant play. i used to be able to run it without problems about 3 or 4 months ago but now i cant.
System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar):
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

citra_log.txt (37.2 KB)

System Information for Support

Client Version                                Canary 1791 HEAD-0e9198e
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 630
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [ ]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hm, since you have i7-7700HQ which usually comes with like Nvidia. Can you go into Device Manager and check if you have more than HD 630 under display adapters?

i have INTEL® HD Graphics 630 and NVIDIA GeForce GTX 1050. idk if thats what you asked for but my main language is not english so im not familiar with the terms

Ah GTX 1050. Since Citra is currently using your iGPU you will need to go into Nvidia Control Panel then in Manage 3D settings, set preferred GPU to Nvidia:

While you are there, set Power management mode to Prefer maximum performance. If you also have GeForce Experience installed, turn off Battery Boost:

thanks, that worked. the game doesnt run at 300% like it used to but i can play it at 170 which is not bad.

same happening with me, all the system info matches. Is there something up with my log?
citra_log.txt (4.0 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hi, try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it’s there
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to slowly load all shaders from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.