Game crashed on loading - Shin Megami Tensei IV

Issue:
When loading Shime Megami Tensei IV, the program crashes without any messages.

System Information

  • Operating System: Linux Mint 19
  • CPU: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx (8) @ 2.100GHz
  • GPU: GeForce GTX 1650/PCIe/SSE2
  • Citra Version (found in title bar): Citra Canary 1861
  • Game: Shin Megami Tensei IV
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (12.9 KB)

System Information for Support

Client Version                                Canary 1861 HEAD-9c0666d42
Operating System                              Linux 5.4.0-48-generic
CPU                                           AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx  
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1650/PCIe/SSE2
GPU Driver Version                            450.80.02
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Canary 1861 HEAD-9c0666d42
Operating System                              Linux 5.4.0-48-generic
CPU                                           AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx  
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             GeForce GTX 1650/PCIe/SSE2
GPU Driver Version                            450.80.02
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hi, please try this:

  1. Open Citra then go to File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder if it is there.
  3. Emulation->Configure… then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication (if it hasn’t been activated already)

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

Hello,

I’ve tried that, didn’t work :(.
Any other suggestion?

Thanks!

Try turning off Hardware Shaders in emulation>configuration>graphics>advanced