Gamepad issue in Zelda: Link between Worlds

I am having problem with the gamepad in the game Zelda: Link between worlds.

The problem is that the direction Link is walking is slightly off, so to say that the cross is misaligned, so when I press up link walk a little off, same in other directions.

I have tried to recalibrate in Windows, in settings of Citra, using 2 different gamepads, using different analog sticks on the pads etc. I then tried to play other games I had, and it seems to work better, for example Pokemon Alpha Sapphire the guy walks perfect up/down on exact same settings.

  • Operating System: windows 7
  • CPU: i7-6700
  • GPU: GTX 970
  • Citra Version (found in title bar): HEAD-8fdd45f but also existed in earlier version
  • Game: Zelda: Link between worlds

Log:
I have been unable to follow the instructions but if it is needed I will try to complete.

1 Like

I’m having the same issues also. All other games I’ve tried do not have this issue, so I’m guessing its game specific. I also tried the same things you did. Its still playable, but that offset really gets annoying after 20min.

I gave up looking for solutions and I just went on playing. I am so far as on the last dungeon. It surely adds a layer of diffculty, though, when walking on narrow paths! :smiley:

But it is interesting to know it is not my setup but rather something with citra/game.

If I had to guess it’s probably something related to scaling, and whatever code keeps track of where your character is/last was. I’m just an armchair developer though, and coding an emulator is not my scene. That stuff is still beyond me at this point. I’ll probably do the same thing as you, and just run through it anyways.

Yes, at least it has been brought up here and verified by 2 people… so maybe someone will see it and maybe do something to it.

Or not.

Good luck with playing. :slight_smile:

Use “Set Analog Stick” in Citra’s controls configuration. This doesn’t fix the problem, but does make it much easier to deal with. Setting each axis individually seems to make the circle pad behave like an 8-directional pad instead of an analog stick. This works at least as of Citra Nightly 1767 (githash 6f6a9357c).

This GitHub thread has more info. Apparently this is an issue with Zelda: Link Between Worlds. Please pardon the necro-post. This is the first result on Google when searching for this issue, so I wanted to make sure people could find the info.