Games are running insanely fast?

Issue:
I downloaded the emulator around a week ago and it ran very nicely, no issues whatsoever. But when I tried playing something today, the speed of games somehow increased by several folds–
I tried reinstalling it, even tried out older versions of both canary and nightly, but the issue is still the same. Restarting my PC didn’t make a difference as well.

The only thing that changed in my gaming routine was that I tried streaming using OBS, then Geforce Experience. I dunno if this information is useful, but maybe it is

System Information

citra_log.txt (204.6 KB)

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

System Information for Support

Client Version                                Nightly 1347 HEAD-8acd2b9
OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce RTX 2060/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            417.71
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
System Region                                 -1

Here’s some issues I found with your log that might help.

  • You are running out of date drivers for your GPU. You need to install the most recent driver for your graphics card from NVIDIA’s website. https://www.nvidia.com/Download/index.aspx
  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

Enable Limit Speed Percent, it’s in the general tab. Shortcut is CTRL+Z

ahh, thank you so much, it works fine now!