Games not filling available screen size

Issue:
Launching a game in full screen or with window of any size results in the game not using the full space to render. Changing the screen layout works but no configuration allows it to fill the application window. Deleting my qt-config.ini file to have it re-built automatically does not help.

System Information

  • Operating System: Fedora 31 - KDE Plasma Desktop - Linux Kernel 5.6.6
  • CPU: Intel i7-7500U
  • GPU: Nvidia Geforce 940MX (using NVidia PRIME in Xserver)
  • Citra Version (found in title bar): master-bc14f485c (2020-04-25) built using “cmake … -DCMAKE_BUILD_TYPE=Release -DENABLE_FFMPEG_AUDIO_DECODER=ON”
  • Game: All
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (50.1 KB)

System Information for Support

OpenGL Vendor                                 Intel Open Source Technology Center
OpenGL Renderer                               Mesa DRI Intel(R) HD Graphics 620 (Kaby Lake GT2) 
OpenGL Version                                null
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

System Information for Support

OpenGL Vendor                                 NVIDIA Corporation
OpenGL Renderer                               GeForce 940MX/PCIe/SSE2
OpenGL Version                                3.3.0
GPU Driver Version                            440.82
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [ ]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I tried enabling accurate multiplication and got the same result