Games on citra aren't opening

The issue started when I changed the cpu clock speed setting, and even after I changed it back, the game wouldn’t open. I have uninstalled and reinstalled citra and reset all settings but no dice. It just opens to a black screen, and then crashes.

System Information

  • Operating System: Windows 11
  • CPU: Ryzen 5 5500U
  • GPU: Integrated Graphics
  • Citra Version (found in title bar): Citra Nightly 1885
  • Game: Tomadachi Life and more.
  • Screenshot of Issue (include the full Citra window including titlebar)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (50.2 KB)

In order to save a copy of the log, follow this guide:

You appear to have run into a bug that was introduced in a recent update. The developer has been informed and we’re working on getting a fix out as soon as possible.

Yep, downgraded my game and everything is working fine.

We believe we have a fix for the issue. Could I ask you to help with testing?

If so, you’ll need to log into a Github account, then go to this page: gl_rasterizer: Fix texel buffer size overflow by vitor-k · Pull Request #6458 · citra-emu/citra · GitHub

On the right, there’ll be an Artifacts 4 tab. Click on that to expose the download options.
Download the linux-mingw build. Extract it using winrar or 7zip and run citra-qt(.exe). Now try your game again and let us know whether it solves the issue for you or not.

Yep, everything is working fine on the linux build.

Thanks for testing! The fix has been included in the latest Nightly build. Feel free to update to it :slight_smile: