Games won't run well on my gpu

Issue:
Enter a description of your issue here, in full detail.
I have an intel hd graphics 4400 graphics card.Most citra compatible games won’t run correctly on in my gpu.Is there any solution to this problem? I am not allowed to buy a new gpu.

System Information

  • Operating System: Microsoft Windows 10 Professional (x64) Build 15063 (1703/RS2)
  • CPU: Intel Core i3-4160
  • GPU: Intel HD Graphics 4400
  • Citra Version (found in title bar): canary 1979
  • Game: Pokemon X and Alpha sapphire
  • Screenshot of Issue (include the full Citra window including titlebar):

    citra_log.txt (80.8 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1979 HEAD-3a9b369
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-4160 CPU @ 3.60GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4400
GPU Driver Version                            20.19.15.5171
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Canary 1979 HEAD-3a9b369
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i3-4160 CPU @ 3.60GHz | AVX2 | FMA
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 4400
GPU Driver Version                            20.19.15.5171
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [x]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Set your Internal Resolution back down to native and deactivate Accurate Multiplication in Emulation>Configuration>Graphics>Advanced Tab.

Thank you for your reply.I will try your suggestion.

Hello.I tried it.It kinda solved the issue.When I turn off accurate multipication in the game(While using 2x native resolution)the game does not crash for quite a time.But then it stops responding(specially when i open bag in pokemon X and as).

Then I tried turning on Accurate Multiplication and changing resolution to native,fortunately It solves all issues.

But sadly I cant enjoy games in 480p or 720p resolution.

Thank you for your help.If you know any other solution please let me know.

Your hardware is rather old and even in it’s day, it was pretty weak. Combine that with “not so great” iGPU drivers and you get your current situation. It’s always finicky dealing with this type of old, semi-compatible hardware so there isn’t much we can suggest other than what I already have. Running your game at native 100% speed without crashing regularly is honestly the best you could normally hope for.

1 Like