Games work on bleeding edge, but not current versions

I have been wanting to use my ,“New Super Mario Bros 2. Gold Edition” File for a while now with the canary or nightly builds because it is faster, but it only works for the Bleeding Edge version, can someone help me fix this?

Before we provide support, please create another support request that completely, and accurately fills out the template so that we may better assist you.