Generally bad peformance

So I installed a few decent games like Ocerina of Time 3d which is a “Perfect” game according to the compatability list but everytime I launch it is get up to 30% speed and even 0% at dialouge. I want to know if there is any way I can improve my game or if my PC is just TRASH

System Information

  • Operating System: Microsoft Windos 10 Pro
  • CPU: Intel® Core™ i7-3740QM CPU @ 2.70GHz 2.70GHz
  • GPU: 2.70
  • Citra Version : c29ae76
  • Game: Ocerina of Time 3D
  • Screenshot of Issue:

Diagnostic Log

<[ 12.457849] Frontend citra_qt/main.cpp:OnUpdateFound:544: No updates found
[ 33.045393] Frontend citra_qt/main.cpp:BootGame:674: Citra starting…
[ 33.632810] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:514: GL_VERSION: 3.3.13401 Core Profile Forward-Compatible Context FireGL 15.201.1301.0
[ 33.632823] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:515: GL_VENDOR: ATI Technologies Inc.
[ 33.632826] Render.OpenGL video_core/renderer_opengl/renderer_opengl.cpp:Init:516: GL_RENDERER: AMD FirePro M4000
[ 33.635336] Loader core/loader/ncch.cpp:Load:159: Program ID: 0004000000033600
[ 33.635612] Service.FS core/file_sys/ncch_container.cpp:OpenFile:113: Failed to open C:\Users\T0XICxSTR1KE\AppData\Roaming/Citra/sdmc/Nintendo 3DS/00000000000000000000000000000000/00000000000000000000000000000000/title/0004000e/00033600/content/00000000.app
[ 33.704948] Service.FS core/file_sys/ncch_container.cpp:LoadSectionExeFS:275: Attempting to load logo from the ExeFS
[ 33.705568] Service.CFG core/hle/service/cfg/cfg.cpp:SetPreferredRegionCode:602: Preferred region code set to 2
[ 33.868063] Service.SRV core/hle/service/sm/srv.cpp:RegisterClient:48: (STUBBED) called
[ 33.869270] Service.SRV core/hle/service/sm/srv.cpp:EnableNotification:70: (STUBBED) called
[ 33.877703] Service.APT core/hle/service/apt/apt.cpp:GetLockHandle:255: (STUBBED) called applet_attributes=0X00000000
[ 34.027803] Service.APT core/hle/service/apt/apt.cpp:NotifyToWait:234: (STUBBED) app_id=768
[ 34.037624] Service.APT core/hle/service/apt/apt.cpp:AppletUtility:455: (STUBBED) called command=0X00000007, input_size=0X00000004, output_size=0X00000001
[ 34.039094] Service.APT core/hle/service/apt/apt.cpp:AppletUtility:455: (STUBBED) called command=0X00000004, input_size=0X00000001, output_size=0X00000001
[ 34.092721] Service.GSP core/hle/service/gsp/gsp_gpu.cpp:AcquireRight:666: called flag=00000000 process=10 thread_id=0
[ 34.207279] Service.DSP core/hle/service/dsp_dsp.cpp:LoadComponent:150: Firmware hash: 0x4b1ec1487e523c5a
[ 34.207292] Service.DSP core/hle/service/dsp_dsp.cpp:LoadComponent:154: Structures hash: 0xd194fc96db654a27
[ 34.207297] Service.DSP core/hle/service/dsp_dsp.cpp:LoadComponent:159: (STUBBED) called size=0xBE0C, prog_mask=0x000000FF, data_mask=0x000800FF, buffer=0x0054CC8C
[ 34.209687] Service.DSP core/hle/service/dsp_dsp.cpp:RegisterInterruptEvents:251: Registered type=2, pipe=2, event_handle=0x0009001E
[ 34.210509] Service.DSP core/hle/service/dsp_dsp.cpp:GetSemaphoreEventHandle:176: (STUBBED) called
[ 34.211299] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphoreMask:473: (STUBBED) called mask=0x00002000
[ 34.212731] Audio.DSP audio_core/hle/hle.cpp:PipeWrite:149: Application has requested initialization of DSP hardware
[ 34.213288] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphore:274: (STUBBED) called
[ 34.225045] Service.DSP core/hle/service/dsp_dsp.cpp:SetSemaphore:274: (STUBBED) called
[ 34.300898] Kernel.SVC core/hle/kernel/svc.cpp:CreateThread:750: Newly created thread must run in the SysCore (Core1), unimplemented.
[ 34.412876] Service core/hle/service/service.cpp:ReportUnimplementedFunction:163: unknown / unimplemented function ‘SetInternalPriorities’: port=‘gsp::Gpu’ cmd_buf={[0]=0x1e0080, [1]=0x19, [2]=0x1a}

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

uncheck ‘Enable Hardware Shader’

I did do that but it only went up to 50% then back to 25%

This does not tell me your CPU. You will want a CPU with high single-core performance to get the most out of Citra.

https://www.cpubenchmark.net/singleThread.html

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

I’ve updated it to show my cpu

Try go into power settings and set the profile to high performance. Double check that the max processor state is set to 100%.

I did this and it got me up to 71%

@GambaXP “Perfect” in the compatibility list means that the game will work and emulate fine without any graphical problems. However, this doesn’t mean that the game will also run at max speed. You still need a CPU with high single-core performance (as said by @Leo121) to make the game run at full speed.

And next time, please post your problems with full information. Yeah, you did update the info of CPU, but you have only a number listed on GPU, which doesn’t tell something at all.

Thanks for the info, I’ll keep that in mind

also had a performance issue in some games. they where running @ 50-75% speed.
i noticed that my start option in Win10 changed itself.
i changed the start option back to my settings and it works now at 100% speed in most games(with a few short drops.)

Press Windows Key + x from the keyboard->type msconfig->Click on Boot->Advanced Options->Check on Number of Processors->Now select the Processor that you want to activate->Click on Apply->OK.