Generic control error to open

When I try to open the two versions of citra with the generic control of the xbox, they start by altomatically close by themselves, and when I open the program with the control disconnected they open without problems, but when I reconnect the control Citra automatically closes again, Any extra information you need is just asking me, but please help me.

System Information

  • Operating System: Windows 10
  • CPU: Corei7
  • GPU: Nvidia Geforce 1060 TI
  • Citra Version: Citra Nigthly 1156/ Citra Canary 1134
  • Game: All

Diagnostic Log
citra_log.txt (6.4 KB)

In order to save a copy of the log, follow this guide:

In order for us to provide better support, we need to see the log generated by Citra. This guide will walk you through how you can obtain the log file: How to Upload the Log File.

iirc citra can behave like that, i don’t remember if this issue has been fixed but a workaround is to only connect your controller after you have launched a game.

even so after starting the game the program closes anyway, as soon as I connect the control, I already tried the two versions, I do not know what to do, so I’m coming to speak directly with you, please help me.

There is an open issue here. try installing the Xbox 360 Controller for Windows driver and see if it works.

Unfortunately the way they used them has no function, maybe because my system is kp-4033, but even installing the microsoft driver the result was ineffective in the same way, has the other thing we did to solve the problem?

what other thing are you referring to? as a possible workaround you could try x360ce, just open x360ce.exe, at first it will ask to download a basic config, just click ok or next, save and close x360ce, this will generate two files x360ce.ini and xinput_3.dll, paste this files inside the citra folder where the citra-qt.exe resides.

was inefficient in the same way, unfortunately I think I’ll wait for future citra updates to resolve this problem, but thanks for trying to help me

you can also try older nightly builds and maybe help find if it worked in the past and if so in which build did this issue began. for instance you could bisect from, say nightly-500, (or older if that doesn’t work), just download and extract to a separated folder.

go up or down depending if the newer or the older build works. just change the number on the end of the URL to see the download page for that specific nightly build.