Gets OpenGL 3.3 not found error even though the computer supports OpenGL 4.1

Issue:
On my MacBook air mid 2012 Citra gives the “Your GPU does not support OpenGL 3.3” error even though Apple and the OpenGL Extension Viewer app says that it supports OpenGL 4.1.

System Information

  • Operating System: OSX 10.13.6
  • CPU: 1.7 GHz Intel Core i5
  • GPU: Intel HD Graphics 4000 1536 MB
  • Citra Version (found in title bar): Nightly 1168
  • Game: NA, though I am testing Citra with Pokemon SMD* Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (8.4 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

There is no osx build for 1148 and so cannot download for mac

Also, further, i found this in the given link, which states that If nightly build 1148 still works, then the cause must be out of our scope because the change from 1148 to 1149 is pretty unrelated and trivial af. It might be that travis CI and/or MacOS silently updated something. Could anyone compile citra locally and test if it still works?

If this is the case then can citra resolve this problem with a future build?

I am having the same problem on the same mac build