Graphical errors in Ultra Moon

Issue:
Running Ultra Moon on Canary was just fine before I updated. After that, parts of the screen became solid colors.

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (236.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Canary 1654 HEAD-da3ad94
OpenGL Vendor                                 Intel
OpenGL Renderer                               Intel(R) HD Graphics 4600
OpenGL Version                                3.3.0
GPU Driver Version                            20.19.15.5058
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             null
Enable Shader JIT                             [x]
Enable Vsync                                  null
System Region                                 -1

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Hi, can you test latest Nightly and this build? https://ci.appveyor.com/project/bunnei/citra/builds/32238065/job/616dd2ve0j2v8ro4/artifacts
Tell me if the link is the same as Canary while Nightly is fixed.

Citra nightly has the same problems and the other build works, but runs at nearly 1 fps during transitions between battles and loading screens.

Oh ok, can you quickly check on Nightly if you turn off Accurate Multiplication fixes it?(re-enable it afterwards because it’s needed for the shader cache to work properly).

Ok, while Accurate Multiplication is off, the graphics look fine again, but turning it back on causes them to revert to the blocks.

I see, thanks for testing. I guess Intel drivers for your GPU doesn’t like the setting :stuck_out_tongue: however the build I linked you is trying to tweak it for the better.

Thanks for the help.

Though I can see your drivers are a bit outdated

Download win64_15.40.45.5126.zip from https://downloadcenter.intel.com/download/29474/Intel-Graphics-Driver-for-Windows-15-40-?product=75045
direct link: https://downloadmirror.intel.com/29474/a08/win64_15.40.45.5126.zip

then follow this guide to install it: https://www.howtogeek.com/343287/how-to-fix-the-driver-being-installed-is-not-validated-for-this-computer-on-intel-computers/