Graphical issues with Canary on AMD and Intel GPUs


Same here, any game I have who uses 3D graphics is crashing on lastest canary builds using GPU option, I think I will pick the older canary builds.


It works fine is still black even going to CPU, please you can do this, come up with an update that allows me not to go to “system” option where it is 7 frames/s, love your work guys, keen to play on my AMD run computer


i have error running video core help pls


i am new to this emulator, but i have a problem, i tried both nightly and cranary build but my game keep blinking white. my spec : amd fx8300 ram 8gb gpu rx460 2gb


nevermind it fixed when i close msi afterburner


I can for the first time the GPU, and nothing happened, but when I put Vsi, or something like that, I started to browse the graphics, is not there a way to eliminate the configuration without deleting the saved?


It seems it works with Intel GPUs now, but it glitches a bit


What iGPU do you have?


only says: intel celeron CPU 3215U 1.70GHz 1.70 GHz


@Hexagon12 my iGPU is Intel HD 4000. The glitches i’m talking about are like the glitches from before, but they only happen for less than half a second, and they happen constantly, but for the rest of the time the game looks normal. Still way less buggy than before.


Can you please say what is the minimum requirement for playing pokemon roms on citra at full speed.please …


Don’t repost the same message on multiple threads.


UPDATE: Try out the latest Canary build (483) for those who had flickering issues with Nvidia GPUs.
The change was to fix the uniform buffer from *2 to *1 while still keeping the AMD *2 in vertex buffer.
I would request all AMD users to retest for possible regressions with the new update!


That fixed the issue for me! Thank you :star_struck:

Overall, the speed boost given by the GPU config isn’t much, but it definitely runs better

EDIT: Actually scratch that, i tested it in a place where it lagged quite a bit, without the FPS limiter, and it actually got a 20 FPS boost. That’s incredible


It seems that for Mac users we couldn’t select the use of GPU/ CPU. Would it be a feature to be implemented in Mac version soon? And as far as I observe this feature has been merged to nightly too.


The GPU function has been renamed to Enable Hardware Shader.


i download the latest canary version already but i still doesn’t have the GPU option


Again, this is what it has been renamed to.


hi guys pliiz hlep me i dont faund this new updat