Graphical issues with latest Canary in Monster Hunter XX

Issue:


as you see, the valentinvanelslande 213 build runs without issue, but Canary 495 build renders wrong graphic

System Information

  • Operating System: Windows 10 64bit
  • CPU: Intel i5-8400
  • GPU: Intel UHD Graphics 630
  • Citra Version (found in title bar): HEAD-38512bf
  • Game: Monster Hunter XX
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296citra_log.txt (19.9 KB)

I did not find anything wrong in your log file. Please wait for a moderator to assist.

It’s up to unofficial build developers to upstream their changes to Citra.

@CodingKoopa
No, he means it wasn’t happening before in citra canary and started happening in version 495 or a bit before that. I have the same issue as him on a windows 10 64 bit on an AMD video card.
Since you mentioned valentin’s build, it also happens on his latest 214, but not on the 213 as the op mentioned.
I have not tested other games to see if they have the same shadow issue after the 495 update.

Ah ok. It would help to find out the exact Canary version where the regression occurred (the first broken version.).

does that also happen on monster hunter x?
if so, where does it happen? everywhere?
i can confirm that canary 495 still has shadows on bherna village.

HD 6750 btw.

i just tested, 495 works, 496 and above doesn’t.

The two relevant Canary merge logs are:

Between these two, the only GPU change between these two that have a different commit that I noticed is in #3729. 495 is on commit 8606608, and 496 is on commit 5f3b640. Linking this to that PR.

@CodingKoopa
Alright i’ve tested it as well on mhXX and the issue appears on 496, but not in 495 unlike @naruga mentioned in the op, at least for me. 495 works fine.

Pic is 495 on the left and 496 on the right. It’s basically a giant square shadow that moves with your character, covering the ground.

maybe it’s because I’m Intel GPU and you are AMD GPU

i just tested shadow map 2D Image load/store version and shadows are working again.
canary building still in progress btw.

1 Like