Grey Screen in Citra when Hardware Renderer is enabled

#1

I have Been recently trying to play pokemon moon on citra, It runs 40-60 FPS when Hardware rendering is enabled but the screen is grey. When I disable it, the FPS drops to 1-2 but the grey screen disappers
Forget to mention, I have disabled Hardware Shader Thats why some figures are showing otherwise on enabling it the screen goes completely grey.

System Information

  • Operating System: Windows 7 Ultimate
  • CPU: Intel Core i5 - M 460 2.53 GHz - 4GB RAM-64 bit
  • GPU: ATI Mobility Radeon HD 4650 (1 GB)
  • Citra Version (found in title bar): Citra Nightly #939
  • Game: Pokemon Moon
  • Screenshot of Issue (include the full Citra window including titlebar):

citra_log.txt (3.3 KB)

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

your log is incomplete, launch your game, reproduce your issue (where the gray screen occur), close citra and upload your log.

#3

Here is the log file
citra_log.txt (19.3 KB)

#4

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#5

Have you installed the latest driver update for you GPU from the AMD website? if you look for the latest driver you can see Driver Details which shows the version of the driver, look on you AMD control panel and verify if its the same version, if yours is older download and install the latest.

#6

The Driver installed is latest.
I have rechecked that

#7

Try citra canary, and test with ‘Enable Hardware Shader’ disable/enable before launching a game.
btw your GPU is a little too old, it may be the issue here.

#8

Got it. So what kind of gpu best suited for citra? so that pokemon games run smoothly

#9

Try this setting

#10

Tried the setting mentioned, But it didn’t work. With the those settings now screen is completely grey but game works at full speed :frowning:

#11

But i still don’t get one thing that why the emulator is showing OKAY in Game Compatibility?.
SInce it is showing that the game should have run okay.

#12

Hardware bugs and speed are supposed to be excluded from compatibility ratings, but users rate the game badly anyway if they have such issues (don’t trust the compatibility ratings 100%).

Have you tried disabling Hardware Shaders and Accurate Multiplication? Did it change anything?

#13

Disabling it only shows some part of game, rest is still grey