Grey screen while trying to load any game (and low FPS if video is showing) (Solved!)

#1

Issue:

Good evening. I have been trying to emulate certain games with the lastest version of citra. The game loads fine with 30 FPS or higher, but when it reachs the main menu screen the side were it should be the title of the game is all in black and I can only interact with the tactil one. Once I start the game, the smaller screen always work how it should, but the bigger one, If in an action scene, everything will be grey. And if is just viewing stats, it will be black. You can hear the music just fine but will glitch if the screen is not grey.

If I have enable Hardware renderer & shader it will present the issue in question. If I only have enabled “Shader JIT” the video will show but at a maximum of 2-5 FPS and glitched audio.

My OpenGL version is 4.2

System Information

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.

Canary Log with Black screen while in the prologue: citra_log.txt (25.0 KB)
Canary Log with grey screen while reproducing a video: citra_log.txt (22.5 KB)

In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

#2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#3

Your GPU driver is outdated, download and install the latest driver for your GPU from the manufacturer website.

#4

Thank you for your answer. I had a slightly suspect about the drivers, but I do not wanted to do an irreversible damage if I just happend to download the wrong version. In the AMD page they give me two version for download: Catalyst Software Suite and Radeon Software Crimson Edition Beta. I’m downloading right now the Catalyst since I have seen the program here and there (when I right-click in desktop) or is necessary to download both? Thank you again and my apologies if this results in a dumb question.

#5

For non-gcn AMD GPU’s, AMD really offers these two drivers, 15.7(latest catalyst) and 16.2.1(crimsom),
both work fine and both have the same OpenGL support (i’m not 100% sure, but if not, they are still 99% the same regarding OpenGL support).

#6

Hello again. I have installed the catalyst version, and the only thing it actualiced was a c++ component from microsoft, a screen component and the catalyst itself. After that, I restarted the PC (just in case) and opened citra to… nothing. It presented the same problem even after the update, so I tryed to check from the device manager and checked for updates for the AMD. It told me that the AMD is using it lastest updates and cannot be upgraded for the moment. So, should I try with the Crimson driver or now is another problem of my PC? Thank you for your patience. (By the way, I have updated Citra with today’s upgrade)

#7

open citra, reproduce the issue again, and upload your log again.

#8

citra_log.txt (25.0 KB)

Here you go.

#9

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#10

You log is showing the same gpu driver version, you need to open citra again, launch the game and play until your problem occurs, close citra, open the log folder C:\Users\%username%\AppData\Roaming\Citra\log and upload citra_log.txt again.

#11

Uhm, well, I tried playing a new save and this time the video came a little more late and the FPS dropped. Then the audio glitched and Citra crashed:

1st Crash: citra_log.txt (22.5 KB)

I played again and this time there were no FPS drops, but when I pressed to pass the conversation it crashed:

2nd Crash: citra_log.txt (23.0 KB)

In the first crash I had enabled all graphical options but “Accurate Multiplication”, and in the second crash that option was enabled.

#12

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#13

I played again without the accurate multiplication and shader, and the game did not crash but the screens were the same (grey while in a video and black in game)

citra_log.txt (27.3 KB)

#14

I did not find anything wrong in your log file. Please wait for a moderator to assist.

#15

Are you sure you installed a newer driver successfully?
you can use a tool like GPU-Z and check the driver version.

#16

Hello! Yesterday, I tried update via microsoft the drivers; it did something but the problem still persisted. So, I gave it another shot this morning to update again with the Catalyst, and to my surprise, this time it worked! I opened the Citra and it emulated without problem Bravely second.

I want to thank you for your patience and support through this entire problem, and apologise for all the dumb questions that I made and probably annoyed you haha! Thank you so much again, and hope you have a wonderfull day!

1 Like
closed #17