Hardware Renderer & Missing Textures


#1

Issue:
When using hardware renderer, games run at 100% speed, but random graphics/textures are missing from every game. (Mac OSX)
When I turn OFF harder renderer, the graphics are perfect (but the game is unbearably slow, like 12% speed.)
Hoping to fix the renderer issue so that I can run the games with that option at full speed.
Thanks in advance!

System Information

  • Operating System: Mac OS Seierra 10.12.6
  • CPU: 2.7 GHz Intel Core i7
  • GPU: Intel HD Graphics 3000 512 MB
  • Citra Version (found in title bar): HEAD-cf9bfe0
  • Game: Bravely Default (but every game actually)!
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log.txt (92.5 KB)


#2

I did not find anything wrong in your log file. Please wait for a moderator to assist.


#3

Turn off Hardware Shader instead of Hardware Renderer.


#4

Hi thanks for the reply – but actually I already have. Here are my current settings
(turning off shader JIT doesn’t do anything, either)
it might also be worth adding that i have tried every combination of settings available in the configuration “graphics” window to no avail.

20%20PM


#5

Turn on all the checkboxes in the Renderer group.


#6

thanks, but as i stated above: i have already tried every combination of “checks” in this window. (literally every combination)
it might also be worth mentioning; if i check all the boxes in renderer group, i actually lose EVERY image and only am left with black screen.
im wondering if this is perhaps a Mac issue with a recent citra update


#7

You have a Mac? Hardware Shaders won’t work for you. Disable them, and reduce resolution to native. And hope for the best.


PS.: Sorry I forgot to check the system information.


#8

hi thanks a lot for the suggestion.
sadly that didnt work either.
i turned off shaders, reduced resolution to native and it produced the exact same results as the original screen shot.

anyone here have any ideas?


#9

Try redumping the game.


#10

as i had posted above, it is any and every game i try. no matter how many times i redump


#11

Can you test on a machine running Linux/Windows? Mac has very bad OpenGL support.


Your gpu is too weak for Citra, unless you’re using Mesa drivers. However, you should get a video core error in that case, which you clearly aren’t getting (maybe cuz Mac OS = mad OS?). I would recommend upgrading.


#12

i cannot test on another machine. trying to get citra to work on this one.
runs at 100% speed, just missing textures from the graphics


#13

looks like a new nightly update came, but still no fix to this.
seems like others are having similar issues. anyone have any ideas?


#14

As the other person said - macOS has very poor OpenGL drivers and you would get way better performance on this computer if you installed Linux / Windows through BootCamp.


#15

I have exactly the same problem… I have a MacBook Pro Core i5
With the hardware renderer runs great but with missing text
when I turn off the hardware renderer, all the graphics are great but so so slowly
what can I do?


#16

Nothing. Unless Apple decides to fix it’s drivers, which is unlikely as it has already marked OpenGL as deprecated.