Hardware Shader Nightly 1536 Pokemon Sun

Issue:
I was playing Pokemon Sun using the previous Nightly version (I kinda forget which version) for quite a while and it ran well without any bug. And then, I tried downloading the latest Canary version for my second citra in order to let me trade with myself. At first, it told me to update my nightly version to the latest version and I updated it. After I update my Nightly version my Pokemon Sun began to have issue. The Pokemon Sun still ran until I chose the savefile. After I chose the savefile the screen became black but I can still hear the background music and the sound effect of me walking around but i saw nothing, just a black screen. I tried to uncheck the ‘Enable Hardware Shader’ and the blackscreen was gone after I restart the emulation but, my speed decreased to 65%-75% (before it was 90%-100%) and my fps dropped to 15-25 fps (before it was 30 fps). Is there a way to make the Nightly Version goes back to normal without decreasing the performance (speed and fps) of it? and this problem not only happens in the Nightly version but, it also happens in the canary version

System Information

  • Operating System:
  • CPU:
  • GPU:
  • Citra Version (found in title bar):
  • Game:
  • Screenshot of Issue (include the full Citra window including titlebar):

    The Pokemon Sun ran well in this savefile menu but, when I click it the blackscreen happened

    It became black but I could still hear the background music and sound effect of me moving and when I unchecked the ‘Enable Hardware Shader’ the fps dan speed decreased

    the speed and fps drastically decreased

Diagnostic Log
Upload your log file as an attachment by dragging & dropping.
citra_log.txt (504.9 KB)
In order to save a copy of the log, follow this guide:
https://community.citra-emu.org/t/how-to-upload-the-log-file/296

System Information for Support

Client Version                                Nightly 1536 HEAD-36809b2
Operating System                              Windows 10 (10.0)
CPU                                           Intel(R) Core(TM) i7-7700HQ CPU @ 2.80GHz
Graphics API                                  OpenGL 3.3.0
Graphics Renderer                             Intel(R) HD Graphics 630
GPU Driver Version                            23.20.16.4973
CPU JIT                                       [x]
Hardware Renderer                             [x]
Hardware Shader                               [x]
Hardware Shader, Accurate Multiplication      [ ]
Shader JIT                                    [x]
System Region                                 -1
Shader Disk Cache                             [x]

Here’s some issues I found with your log that might help.

  • Enabling Accurate Multiplication is recomended in certain games. If you are experiencing graphical glitches, try enabling this option.

I’ve tested it also but, the problem still occurs

Do you only have integrated graphics? Check in Device Manager under Display adapters and see what GPUs you have in your laptop.

My GPU is NVIDIA GeForce GTX 1050

Ok, since Citra picked up your iGPU instead that means you need to go into Nvidia Control Panel then in Manage 3D Settings set Preferred GPU to Nvidia. While you are there also set Power management mode to Prefer maximum performance.

If you have GeForce Experience installed you might need to turn off Battery Boost as well:

Do this as well:

  1. File->Open Citra Folder
  2. Open shaders folder then delete the opengl folder
  3. Emulation->Configure... then click on Graphics on the left
  4. Click on the Advanced tab and turn on Accurate Multiplication

The Disk Shader Cache currently has a bug when Accurate Multiplication is turned off causing it to load all shaders slowly from zero every time you start the game and makes the precompiled cache extrememly large + the RAM usage skyrockets until you crash.

WOW! IT WORKED!
Thank you so much! I can finally continue my game
Hope you have a nice day! :smile:

1 Like