Hardware Shader suddenly turns texture to black

**First of all, thanks your all the hard work which you put into Citra&Yuzu. Its amazing to see how games run like a charm, which wouldnt even start one year ago.
The problem which Im facing happens on both of my systems with a gtx1080ti(Nvidia) and on my r9 290x trix-oc. The logfile is from the R9.
Usually while playing with the Hardware shader on, all textures are smooth and I get around 180-240 FPS on 4K. There wasnt even a single problem on “Omega Ruby”.
Now I tried to play “Pokemon X” with the same setting, but many textures are missing or black.
I switched over to Pokemon Omega Ruby again, and the same problem appeared.
When I turn the Hardware shader off, everything runs fine, but with 50 -70 FPS max.
I know its still playable, but I want to figure out what happened and why I cant get the full experience with the shader on.

I updated my Citra-version twice, since the moment it worked without problems. So I tried to use the last two builds, without a result.
I also updated my GPU with the new beta drivers, but nothing changed. Something definitely happened and I missed it. ^^

Anyway, thanks for your time&help.**

System Information

  • Operating System: Win10 Pro x64
  • CPU: i5 4670 OC on 4,8 GHz
  • GPU: R9 290x Trix-OC on 1350 Mhz
  • Citra Version (found in title bar): Citra Nightly 1282 and Canary 1372
  • Game: Pokemon X and Omega Ruby
  • Screenshot of Issue (include the full Citra window including titlebar):

Diagnostic Log
citra_log1.txt (125.2 KB)

edit : Similar threads and all without a result

Link1

1 Like

System Information for Support

Client Version                                Nightly 1282 HEAD-bb776e2
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon R9 200 Series
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1282 HEAD-bb776e2
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon R9 200 Series
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

System Information for Support

Client Version                                Nightly 1282 HEAD-bb776e2
OpenGL Vendor                                 ATI Technologies Inc.
OpenGL Renderer                               AMD Radeon R9 200 Series
OpenGL Version                                3.3.1
Enable Hardware Renderer                      [x]
Enable Hardware Shader                        [x]
Hardware Shader, Accurate Multiplication      [x]
Hardware Shader, Geometry Shaders             [x]
Enable Shader JIT                             [x]
System Region                                 2

I did not find anything wrong in your log file. Please wait for a moderator to assist.

Actually I was convinced, that it couldnt be the new Adrenalin driver, which caused the problem, but I was wrong.
I did a roll back on the Adrenalin 19.4.3 and it worked.
So if anyone experienced this problem, just downgrade your AMD drivers.
I hope they will fix it.

edit : I guess I have to roll back on my Nvidia card, too…

2 Likes

That solved my problem here and not only with Citra but a lot of other games
Thank you very much

1 Like

i registered to say thanks. I have a gtx1070 and after i installed a older version it worked.
its much better to enjoy than this crappy graphic glitches.

Im glad it helped.
The game looks indeed much better without the typical shader-glitches.

1 Like

thx it worked !!!